Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2010
    Location
    Pittsburgh, PA
    Posts
    9

    In-line fuel Filters

    On our 1999 Spx, we have pulled and cleaned the tank, replaced all the fuel lines, cleaned all the filters, changed the fuel selector, had the carbs rebuilt, took it out and ran better than ever. Took it out a week later and back to bogging on acceleration and only idling. Pulled the filters in the carbs and they are dirty. I don't understand where it is coming from if everything has been replaced and cleaned? It was suggested that we leave the filters out of the carbs and put inline filters in? Has anyone done this? Any other suggestions on something to try, or would this be the solution? Thanks!


  2. #2
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Are the filters clogged up with black fine pieces of rubber?

  3. #3

    Join Date
    Jun 2010
    Location
    Pittsburgh, PA
    Posts
    9
    It was more like fine sand, kinda tarish. Only one was really bad and full, the other had just a bit

  4. #4
    Petron's Avatar
    Join Date
    Aug 2008
    Location
    Boston
    Posts
    923
    +1
    1
    When you pulled the tank did you re-use that same gas? was it old? Hopefully you filled up with fresh gas?

    You said "cleaned all filters". I'd replace them (fuel filter, internal carb filters), they're cheap enough.

  5. #5
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Did you clean the fuel/water separator as you never seemed to mentioned it ?
    I remember once I changed fuel lines on a xpl and cleaned all the system from tank to carbs and had the same thing happen.It was the new fuel line internal surface breaking down only where you slide the hose over the fuel spigot's as it was a tight fit. When I forced it on it would rub away ever so slightly internally.Multiply this by all the spigot's it ends up in the filters again.
    I tell people to remove the filters in the carbs all together as the fuel/water separator has the same micron filter element in it.
    And if anything does get by the particles are small enough to pass through the low speed jets (smallest) any how which is where the problem occurs all the time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. In-line fuel filters and oil pump + pre-mix
    By meganosky in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-25-2015, 10:36 AM
  2. In-Tank fuel filter
    By ltmark in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 06-23-2012, 09:32 PM
  3. Making an in-line fuel restrictor-
    By Buck3yeRideR in forum Polaris Open Discussion
    Replies: 10
    Last Post: 03-18-2012, 03:14 PM
  4. in-line gas filter question
    By scottyj in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-26-2007, 11:36 PM
  5. In line fuel filter
    By co_tec2002 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-23-2007, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •