Results 1 to 2 of 2
  1. #1

    1996 polaris slx780 no compression 1 cylinder

    I did a compression test on all three cylinders and had 107 on two and zero on the third.
    I pull the cylinder off and looked at the rings and they looked good the sleeve is clean. Did I screw up the connecting rod bearing?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,577
    +1
    1,272
    107 PSI seems low on the other two cylinders.

    When checking compression, throttle must be held wide open, all spark plugs out.

    Can you see or feel any vertical play in the zero PSI piston?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Polaris SLT700 no fire?
    By Tyras398 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 06-25-2010, 03:11 PM
  2. 1996 polaris slx780 drive system
    By polarisman in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 11-13-2009, 09:39 AM
  3. 1996 Polaris SLTX No Spark troubleshooting question
    By aaron85207arizona in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-02-2009, 09:44 AM
  4. 2002 Polaris Genesis No compression On middle cylinder.
    By polarisbuyer in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-14-2008, 04:12 PM
  5. 1300 no compression rear cylinder
    By OCFZR in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 08-31-2006, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •