Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    yewhoo...my skii runs fine now...

    i tested my skii yesterday and ...from 10am unti 4pm...I emptied my tank thanx a lot to ph2craft and sealion...without these guys, i don't think i can fix my skii.... before i was using a different cdi and fuel pump...going me crazy of tuning the craft , but now... its fine thanx.... but i have a different problem again...i broke my steering cable where can i buy one???


  2. #2

  3. #3

    Talking Cable

    Do not buy that cable on EBAY,it will not fit your SLX!! Bad news is that finding a used cable for cheap is almost impossible! Everyone wants one to install the extended pump in there SL boats. The correct part # is 7081110 $155 retail

  4. #4
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    Andy, way to go. Finally! Too much turning and burning can lead to a broken steering cable now that it runs fine.

  5. #5
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by andy95'slx780 View Post
    i tested my skii yesterday and ...from 10am unti 4pm...I emptied my tank thanx a lot to ph2craft and sealion...without these guys, i don't think i can fix my skii.... before i was using a different cdi and fuel pump...going me crazy of tuning the craft , but now... its fine thanx.... but i have a different problem again...i broke my steering cable where can i buy one???
    Andy that's awesome, be sure to verify your piston wash, I have tons of picts in my gallery for the correct pattern and what it's all about.

    Contact John Zigler, he just got some boats in, he'll have a cable!

  6. #6
    S12L00X's Avatar
    Join Date
    Sep 2006
    Location
    S.E. Michigan
    Posts
    168
    I had my steering cable break on my 95 SLX. It is fun riding when you have no steering. Kind of expensive for a new one but it is pretty easy to put it in.

  7. #7
    javiert99's Avatar
    Join Date
    Aug 2006
    Location
    Jupiter, FL
    Posts
    374
    Congrats man, I know you've been working with that ski for a while now from afar! It's a good feeling to get 'em running....

  8. #8
    Quote Originally Posted by prochamp View Post
    Do not buy that cable on EBAY,it will not fit your SLX!! Bad news is that finding a used cable for cheap is almost impossible! Everyone wants one to install the extended pump in there SL boats. The correct part # is 7081110 $155 retail
    That number ( 7081110)is no good but 2200893 is what u want partsland has them 120.00

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Zig just got a couple of boats with the extended pumps in, he'll have a cable.

  10. #10
    craft, do i need to open the head to check the piston wash??? I can see from the plug holes.. and the piston is color black..and i also observed im a little rich because when i have long highspeed..when going back to idle, my craft will load up and take a sec. before accelerating hard again, but when i let it idle for long time then rev it, i can feel the hard pull..

    javier99, its been two years man, hehehe..fixing and tuning this craft =), I just enjoyed it running for the first time hehehe

    thanx to bmpolaris by the way, he's the one sent me the cdi

    still have little things to fix on my skii, from the cables, mfd, trim, i will just fix it one by one.... =)
    Last edited by andy95'slx780; 10-11-2006 at 10:50 PM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. why is my polaris slth running fine for a bit then dying out
    By kastay29 in forum Polaris How To & FAQs
    Replies: 26
    Last Post: 06-14-2011, 01:11 PM
  2. Lost my idle, was running fine. Please share if you experienced this.
    By artificialreef in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 08-15-2010, 12:13 AM
  3. Replies: 8
    Last Post: 11-21-2008, 10:11 AM
  4. Is My Ski BULLET PROOF Now?
    By Totallyblown in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-25-2006, 10:32 PM
  5. Fired my first flare just now...ouch
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 12-10-2005, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •