Results 1 to 4 of 4
  1. #1

    Broken Anode when installing Riva Open Loop

    I was installing a Riva Open Loop plate and the anode broke as I was installing it. I put the thermo. block off plate on first and then screwed in the anode. Has this happened to anybody else? Did I screw it in too far? Can I simply order another one from Riva? Thanks!


  2. #2
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    I did the same thing, it was actually a little bent and I tried to straighten it out and it broke off. Went to West Marine and picked up a new one for less than $5.00

  3. #3
    Mine seemed like it bottomed out when i was screwing it in- and then broke off. btw- what injectors and ecu r u running? Thanks

  4. #4
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    I run 80lb injectors with a Les Cooke 9200 rpm ecu....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RIVA Open loop plate w/closed loop cooling!
    By dduck1628 in forum 4-Tec Performance
    Replies: 173
    Last Post: 04-07-2014, 12:01 PM
  2. Riva Open Loop Install
    By race24x in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-12-2010, 04:06 PM
  3. RIVA OPEN LOOP Install
    By repsol in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-06-2009, 10:22 PM
  4. riva open loop fitting,info
    By MARK_LEGG in forum 4-Tec Performance
    Replies: 24
    Last Post: 09-01-2009, 04:26 AM
  5. Riva open loop cooling and the new plate
    By bobluen in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-30-2009, 06:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •