Results 1 to 6 of 6
  1. #1

    Join Date
    Apr 2010
    Location
    Vladivostok, Russia
    Posts
    65
    +1
    1

    low oil pressure warning and more...

    after doing wot runs and then fully releasing throttle I always get low oil pressure warning (but no buzzer). However, once throttle is applied again, warning is gone. Also, if I don't release throttle all the way, but keep rpms above trolling speed (1600+) and keep engine running like that for a minute - warning doesn't come. Suspected not sufficient oil cooling at first, but this bike (FZR) has R&D engine cooling and I have second one (FZS) with exactly same setup and no such problems there (both bikes are Riva Stage 3). Have anybody experienced the same?

    Second problem is weird - engine stalled today while I was doing high speed full throttle run offshore. Something not funny while hitting waves. Managed to stay in seat, but got all type of illumination on dash: warning light, green L-Mode light and all indicators on LCD simultaneously. Engine didn't want to crank. Pressing Stop switch, disconnecting lanyard didn't help - even without lanyard dash kept working. Bilge pump was working also. I disconnected battery, connected it again and bum, problem was gone. Made it to shore, checked all connections and fuses suspecting short circuit, but no, everything seems ok. Any thoughts?


  2. #2
    PETRUS's Avatar
    Join Date
    Sep 2008
    Location
    Gulf of Thailand
    Posts
    362
    Quote Originally Posted by Denis View Post
    after doing wot runs and then fully releasing throttle I always get low oil pressure warning (but no buzzer). However, once throttle is applied again, warning is gone. Also, if I don't release throttle all the way, but keep rpms above trolling speed (1600+) and keep engine running like that for a minute - warning doesn't come. Suspected not sufficient oil cooling at first, but this bike (FZR) has R&D engine cooling and I have second one (FZS) with exactly same setup and no such problems there (both bikes are Riva Stage 3). Have anybody experienced the same?
    Yep! similar situation here: low oil pressure warning (w/ flashing red light but no buzzer) anytime I hold WOT for more than 10-20 secs, disappears as soon as I release throttle, only appears when holding WOT
    same set-up stage 3 FZ with Riva IC and R&D cooling kit

    Can the pros chime in

  3. #3
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Riva said something about that to me.
    Suggested I run my oil level high on the stick rather than in the middle of the marks.
    I only have two hours but it never happened to me.

  4. #4
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Quote Originally Posted by PETRUS View Post
    Yep! similar situation here: low oil pressure warning (w/ flashing red light but no buzzer) anytime I hold WOT for more than 10-20 secs, disappears as soon as I release throttle, only appears when holding WOT
    same set-up stage 3 FZ with Riva IC and R&D cooling kit

    Can the pros chime in
    I'm not a pro, but... Check your oil level, if not near full try it as 1 FAST VE said, and run it near the "full" mark.

  5. #5
    PETRUS's Avatar
    Join Date
    Sep 2008
    Location
    Gulf of Thailand
    Posts
    362
    I checked, it s spot on the high mark, I always keep it this way

    any other clues?

  6. #6

    Join Date
    Apr 2010
    Location
    Vladivostok, Russia
    Posts
    65
    +1
    1
    Also on the high mark.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bearing clearances and low oil pressure
    By brl96 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-31-2013, 07:22 PM
  2. 05 15F Low oil Pressure warning issue 45 hours
    By Marineking in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 06-27-2013, 07:47 PM
  3. low oil pressure warning/buzzer
    By zone 5 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-15-2008, 10:41 PM
  4. Oil Pressure Warning Help!!!!!!!!!!!!!!!!
    By outeka in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-21-2007, 01:39 PM
  5. Replies: 10
    Last Post: 05-31-2006, 09:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •