Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 44
  1. #1

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2

    AFR issues..Please advize !!!

    OK , i have a stage 3 rxp. It has a everything done that you can do. My issue is this, i havent messed with tune etc since april and i was running 8400 rpms and 84. Now i am down in the heat to 8000 rpms and high 70's. My rrfpr was set at like 64 and my afr was around mid 12's at idle and 11.5ish at wot in April....I turned the pressure down yesterday to see where i was at, turned it to 59-60 and my idle went to 11.8 and around 10.9 to 11.2 at wot, isnt a lower readin meaning i am way rich, wouldnt turing fuel pressure down make my afr's go up?Because it isnt?? PLease advize guys...thanks again


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Pretty simple really. The AFR was good when it was cool but now that you can't make as much power it requires less fuel.

    Less pressure is less fuel.

  3. #3

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2

    BUt....AFR

    If i am turning it down....Why are the wot afr's still in the high 10's, low 11's..keep turning it down huh?? HMM>>>Whats safe idle afr's? wot need to be around 11.8 to 12.1 ish right..

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Idle and mid can be in the high 13's until boost kicks in around 5500 RPM's 10 is rich and 14 is lean. Also recalibrate your O2 sensor. A quick check for the sensor is hold a butane lighter un-lit at the tip and your afr should read 10

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by WannabeGoing80 View Post
    If i am turning it down....Why are the wot afr's still in the high 10's, low 11's..keep turning it down huh?? HMM>>>Whats safe idle afr's? wot need to be around 11.8 to 12.1 ish right..
    Because you are running the riva/delphi injectors. They cant handle the high pressure and actually go richer when you turn the pressure down . ( especialy at idle). However if you turn it down below 52-55lbs it will start to turn around and lean out for you.

  6. #6

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2

    OK...here is some more info...

    After checking the o2 sensor and running tests...When i fire up the ski, it reads 9.8 and sits there alot. I did the butanne test with lighter and went from 9.8 to 19.8 and back. Pulled connections from battery..reads zero goes to 20. everything is fine...start ski up and runs at idle 9.8 at 59psi....It will bounce around some after idle, but then at wot its back to 9.8 and doesnt move...WTF is goin on? All the tests in the Inoovative book/paper check out..It calibrates to 0 then checks out fine...This is just odd...Is it a bad o2 sensor even tho its checking out? Or do i have to recalibrate the unit? If so how?

  7. #7
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by WannabeGoing80 View Post
    After checking the o2 sensor and running tests...When i fire up the ski, it reads 9.8 and sits there alot. I did the butanne test with lighter and went from 9.8 to 19.8 and back. Pulled connections from battery..reads zero goes to 20. everything is fine...start ski up and runs at idle 9.8 at 59psi....It will bounce around some after idle, but then at wot its back to 9.8 and doesnt move...WTF is goin on? All the tests in the Inoovative book/paper check out..It calibrates to 0 then checks out fine...This is just odd...Is it a bad o2 sensor even tho its checking out? Or do i have to recalibrate the unit? If so how?
    Sounds like you need to free air calibrate it. Those readings are typical if it were calibrated and not in free air. Sounds like this just started happening? Cause your numbers above are much diff.

  8. #8

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2
    Yes, it just started this today...but i havent checked the afr since april.....and it was perfect....it sits on 9.8 alot...its a little odd actually..How do i free to air calibrate? can u give me a heads up?

  9. #9
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by WannabeGoing80 View Post
    Yes, it just started this today...but i havent checked the afr since april.....and it was perfect....it sits on 9.8 alot...its a little odd actually..How do i free to air calibrate? can u give me a heads up?
    What type of gauge are you using?

  10. #10

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2
    innovative motorsports......lc -1 .....

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1200R Engine/Bog Issue, PLEASE HELP
    By GP1300Racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-14-2009, 08:07 PM
  2. 2002 Kaw 1100 Stx d.i. issues-- please help!
    By sundedriver in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-03-2009, 10:59 AM
  3. 2000 yama 1200r starter issues!!! please read and help me lol
    By 00gp1200r in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 06-03-2009, 12:22 AM
  4. 96' SPX start issues. Please help!
    By goBENGALS in forum 2-Stroke Performance
    Replies: 1
    Last Post: 11-02-2008, 08:01 AM
  5. powervalve issue. please help!
    By jeremy3477 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2008, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •