Results 1 to 2 of 2
  1. #1
    gixxer130's Avatar
    Join Date
    Jul 2008
    Albany, NY

    after storage stuff

    OK,Last ride of the year last year and my 2001 gp1200r would just die. When trying to start it back up it would just click like a car with a bad starter. I found if I pulled the tether off and put it back on it would start back up. Is it as simple as a bad switch? Or could it be something else? Also when coming out of winter storage should I clean the flame arrestors since fogging oil was sprayed through them? Thanks everyone.

  2. #2
    Join Date
    Jul 2007
    Baytown, TX
    bad switch is likely, and easy to diagnose. Just attach your digital multimeter to the lanyard safety switch pins and see how good of a connection you get.

    as for cleaning the F/A's - Ive got no clue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT Storage
    By ERICG1 in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-19-2008, 12:53 PM
  2. uh oh, no storage bin??
    By lextoy in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 11-06-2007, 07:12 PM
  3. storage bin
    By Carlos Miami RXP in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-13-2006, 09:05 AM
  4. storage tray
    By 05gtxsc in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 02-22-2006, 10:22 PM
  5. Storage ques.
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 11-13-2005, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts