Results 1 to 5 of 5
  1. #1

    Exclamation POLARIS SL750 Wont start

    Hey all. I got a 95 SL750 here that has a fully charged battery and tested battery. It clicks but does not turn over. Fuel is full, oil is good. It ran a few weeks ago, now there's nothing. Please help because I want some life from this beast. I got a vin if that helps. I know it ran a few days ago. Help!!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Welcome

    Short the two heavy red cable studs on the start solenoid inside the electrical box. If it cranks, then the solenoid may be bad.

  3. #3

    Anything else

    What else could it be?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by K447 View Post
    ...Short the two heavy red cable studs on the start solenoid inside the electrical box. If it cranks, then the solenoid may be bad.
    Quote Originally Posted by Happenedtoyou View Post
    What else could it be?
    What was the result of the test?

  5. #5
    OLDJETSKIMAN's Avatar
    Join Date
    Sep 2008
    Location
    Greensboro N.C.
    Posts
    514
    +1
    1
    Take the plugs out, try turning it over. if it still just clicks, take the cover off of the drive shaft inside the hull at the rear of the motor, try to turn the engine over by hand. If you cant move it with the plugs out then motor is seized, if you can move it the starters bad. My bet is the starter is bad. Anyway hope this helps! Good luck with it. One more thing make sure all your connections are tight. Make sure your ground cable has a good ground to the engine block.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris genesis wont start once its been warmed up ???????
    By white 1989 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-07-2012, 07:36 PM
  2. Polaris sl900 wont start
    By heflin07 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-02-2011, 09:32 PM
  3. Polaris SLT750 Wont Start
    By mkulczyckyj in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-15-2010, 05:04 PM
  4. polaris slxh wont start
    By bobbyhill6 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-28-2008, 12:31 PM
  5. 94 sl750 wont start!!!
    By ktmrider08 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-24-2008, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •