Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169

    in need of help with my gpr

    2003 gp1300r stock


    i was not having any trouble with the ski until.....

    My mother asks to take it out for a spin.. long story short she sinks it.
    I do not know how.
    I tow it back with the boat and bring it home.

    That night a friend and I drain the block and get it running again.

    Next day we take it for a quick test spin and couldn’t find any leaks..
    But we did have trouble starting it.. We had 2 spray starting fluid in the block.

    After I got home I put some mystery oil in the block, gas, and oil and let it sit for a few days.

    Today I went to take it out for a full day and had a lot of trouble starting it… needed to spray more starting fluid into it and even then had trouble..


    Once it was started it seemed to run strong for about an hour and then the warning light + warning beep came on…
    So I killed the engine to let it rest for about a minute and then tried 2 restart it

    The ski wouldn’t start no matter how long I waited while I was out on the water..

    Good thing I had my friend there to tow me in…



    1) Any ideas on how I can get this thing to start up 1 shot like it use to?
    2) Any ideas why that warning light came on and it stopped running?

    Thanks for your help!


  2. #2
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    Carbs definately need to be gone though. Simply running fresh gas through them will not get rid of all the water droplets.

    How long did you run it (the first time) after you got it running again?

  3. #3
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    Quote Originally Posted by Jolly Roger View Post
    Carbs definately need to be gone though. Simply running fresh gas through them will not get rid of all the water droplets.

    How long did you run it (the first time) after you got it running again?
    No carbs it is a 2003 they have fuel injection check the compression and make sure it is ok did you add anything to the gas to make sure there was no water in the gas tank, I would also unplug every connection and dry it and grease the connections with some dielectric spray so the connections dont rust oh and everyone says the most important thing is get it running right away and run a tank of gas thru it to make sure the motor has no more water in the crankcase you used new spark plugs right.

  4. #4
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    i didn't add anything the gas besides a little mystery oil

    should i add something? if so what?

    Quote Originally Posted by zx11rider View Post
    No carbs it is a 2003 they have fuel injection check the compression and make sure it is ok did you add anything to the gas to make sure there was no water in the gas tank, I would also unplug every connection and dry it and grease the connections with some dielectric spray so the connections dont rust

  5. #5
    fenn's Avatar
    Join Date
    Jan 2007
    Location
    Exit 98, New Jersey
    Posts
    926
    +1
    1
    what alarm went off? did you get the code?

  6. #6
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    here is a thread on what to do when your ski sinks gl http://www.greenhulk.net/forums/show...-Swamped-motor

  7. #7
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    the warning light was flashing and beeping

    Quote Originally Posted by fenn View Post
    what alarm went off? did you get the code?

  8. #8
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    thanks!

    i will add some rubbing alcohol in the gas tank tomorrow.. besides that i did most of that stuff..

    Quote Originally Posted by zx11rider View Post
    here is a thread on what to do when your ski sinks gl http://www.greenhulk.net/forums/show...-Swamped-motor

  9. #9
    Horus's Avatar
    Join Date
    Sep 2009
    Location
    Long Island, N.Y.
    Posts
    169
    maybe i should force another start with starting fluid? once its running take it out and go WOT a lot??

  10. #10
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,495
    +1
    618
    If all else fails , your not far from one of the top GPR gurus around, Carl at ISLAND RACING

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 88x2 with mods in need of help
    By 88x2 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-30-2011, 02:38 AM
  2. 96' spx (polaris guy in need of help! PLEASE)
    By goBENGALS in forum 2-Stroke Performance
    Replies: 2
    Last Post: 11-09-2008, 08:46 AM
  3. In Need Of Help w/2000 SLX
    By rmjsvcs in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-12-2008, 03:36 PM
  4. IN NEED OF HELP 1999 polaris genisis fitch
    By rmjsvcs in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-12-2008, 02:56 PM
  5. I Need Some Help With My Shark !!!!!!
    By sleblanc in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-20-2006, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •