Results 1 to 2 of 2
  1. #1
    EROD Palm Beach Punisher's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    380
    +1
    3

    Fuel / electrical issue need help

    HEY GUY'S I HAVE A PROBLEM WITH MY SKI AND I NEED HELP.WHEN I GO WOT IT HIT'S 8400 RPM'S AND WHEN I GO DO A SECOND PASS IT SPITS AND SPUTTERS AND I CAN ONLY GET ABOUT 7500 RPM'S.IF I LEAVE IT ON IDLE IT'S FINE.IF I HIT WOT RIGHT AFTER THE FIRST PASS IT GOES NO WHERE I HAVE TO HIT THE THROTTLE ACOUPLE OF TIMES SO IT CAN GO. I PUT A 255 WALBRO, NEW PLUGS FRESH GAS, AND I SWAPPED THE COIL,TPS,RIVA ECU,INJECTORS,AND STILL THE SAME PROBLEM.I DID A COMPRESSION CHK AND IT WAS FINE ALSO


  2. #2
    LAZBUSA's Avatar
    Join Date
    Apr 2008
    Location
    Palm beach
    Posts
    193
    +1
    4
    ?????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STRANGE fuel sender electrical issue.....need some help on this one...
    By kwtony in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 02-26-2014, 08:54 AM
  2. 1100 zxi electrical issue need help
    By ridburton06 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-21-2013, 06:58 PM
  3. Replies: 6
    Last Post: 04-25-2012, 08:31 AM
  4. Replies: 0
    Last Post: 04-15-2012, 01:05 PM
  5. ultra lx and 250x fuel issues, need help
    By bluebalz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-12-2007, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •