Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80

    more help please

    i was turning 7700 rpms before, i changed my clutch washers and now i can get 7900. i hit 68.4 today. whats the deal


  2. #2
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    sounds like they were slipping

  3. #3
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    they were slipping alot, before i took the old ones off i put the torque wrench on it and the nut started turning at 10 lbs.

  4. #4
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    what is it slipping at now

  5. #5
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    i torqued them to 22 lbs

  6. #6
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,885
    +1
    496
    Quote Originally Posted by ronnierxp View Post
    they were slipping alot, before i took the old ones off i put the torque wrench on it and the nut started turning at 10 lbs.
    How many hours on the washers?
    Were they ceramic?

  7. #7
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    the new ones are metal, about 30 minutes on washers

  8. #8
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,885
    +1
    496
    Quote Originally Posted by ronnierxp View Post
    the new ones are metal, about 30 minutes on washers
    I mean the old set!

  9. #9
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    o sorry, they were metal but they were the coated ones, the guy i bought it from had them put in there when he bought it

  10. #10
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    no ideas?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 GP1200R - HELP Please! Carb, Throttle Pump and More!!!
    By SoundXplosion in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 09-22-2009, 09:53 PM
  2. 2001 GP1200R - HELP Please! Carb, Throttle Pump and More!!!
    By SoundXplosion in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 09-14-2009, 03:24 PM
  3. more carb sync help PLEASE!
    By xltsp8 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-04-2009, 09:30 PM
  4. More ext pump help please
    By novanuttz in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-03-2007, 02:32 PM
  5. A little more XP800 tuning help please...
    By javiert99 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-08-2006, 12:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •