Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477

    Stage 1 plus riva sc impeller resuslts

    So i put the riva stage I, vts rod, steel washers, race tech free flow and riva sc impeller (thanks to pale rider for the sc impeller) on my stock 06 rxp with 21 hours on it and wow what a difference i dont have a gps so i coudlnt see what my numbers were but it felt amazing and i would also suggest to anyone who doesnt want to drill the hole for the thru hull to get the race tech free flow the resonance that everyone complains about isnt nearly as bad as everyone makes it out to be the olny time i even noticed it when when i first planed out with it and that was it. But i did notice that my rpm's got up to 8350 and i dont think that they were stopping so i have to send my prop back to jerry 2 get pitched.


  2. #2
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    i have the homemade version of your exhaust and i barely noticed it either

  3. #3
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,893
    +1
    502
    Quote Originally Posted by ReDevilRXP View Post
    So i put the riva stage I, vts rod, steel washers, race tech free flow and riva sc impeller (thanks to pale rider for the sc impeller) on my stock 06 rxp with 21 hours on it and wow what a difference i dont have a gps so i coudlnt see what my numbers were but it felt amazing and i would also suggest to anyone who doesnt want to drill the hole for the thru hull to get the race tech free flow the resonance that everyone complains about isnt nearly as bad as everyone makes it out to be the olny time i even noticed it when when i first planed out with it and that was it. But i did notice that my rpm's got up to 8350 and i dont think that they were stopping so i have to send my prop back to jerry 2 get pitched.
    Yea thanks to PR
    But on a up note where do you get that race tech free flow from?

  4. #4
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    I got it from jerrys store the link is below. Yeah sorry about that olkagpr i heard u gave him some heat for that so i appologize for any hard feelings.



    http://www.4-tecperformance.com/inde...roducts_id=312

  5. #5
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,893
    +1
    502
    Quote Originally Posted by ReDevilRXP View Post
    I got it from jerrys store the link is below. Yeah sorry about that olkagpr i heard u gave him some heat for that so i appologize for any hard feelings.



    http://www.4-tecperformance.com/inde...roducts_id=312
    Oh man I dont blam you so dont appologize!

  6. #6
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    your rpms should not be going past 8250 or so with a stock ECU, i would check your wear ring and make sure your limiter is working correctly before i redo the prop.

  7. #7
    RxPrider's Avatar
    Join Date
    Jul 2006
    Location
    lake ozark
    Posts
    298
    I considered the race teech exhaust, but alot of people said the resonance was terrible. Could you get a sound clip, or vid? Thanks

  8. #8
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    Quote Originally Posted by meeper View Post
    your rpms should not be going past 8250 or so with a stock ECU, i would check your wear ring and make sure your limiter is working correctly before i redo the prop.
    My wear ring is a little worn but not much it was a bitch to get the prop inside of it to so i dont think its worn down to bad pkus ive never beach it and taken sand or rocks or anything. How do i check my limiter? im pretty sure it wasnt gona go past 8350 because i held it there for about 5 seconds and it didnt go any further and it got to 8350 like nothing.

  9. #9
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    8350rpm's on a stock ECU?

    WOW, am I missing something?

  10. #10
    Quote Originally Posted by oklagp1200r View Post
    Oh man I dont blam you so dont appologize!
    ReD: awsome results bro, glad I could help you out! Don`t feel guilty, you were the winner!


    Hey okla: we gonna go thru this again?
    I asked Jerry the forum rules for the classified, and "it`s first response with the committment gets it" YOU simply didn`t get back to me in time, so let`s drop it. Your whinning won`t ruin my rep here.
    Any questions ask the site owner!...enough said...PR...
    Last edited by Pale Rider; 10-07-2006 at 06:36 PM.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gen I vs II riva SC impellers
    By braaapf7 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-30-2009, 08:58 AM
  2. Riva SC impeller
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-17-2006, 11:09 PM
  3. riva bov w/ riva sc impeller
    By mxl16 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-07-2005, 02:28 PM
  4. Jerry----Riva SC impeller
    By RXPDAVID in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-27-2005, 08:26 PM
  5. Riva SC Impeller
    By INDY27 in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-01-2005, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •