Results 1 to 4 of 4

Thread: 04' rxp issues

  1. #1

    04' rxp issues

    new to the site but ive read it for awhile so i know you guys are the ones to come to with an issue. as soon as i connect the key it beeps and the display says sensor maybe unrealated to the issue but i figured id throw it in anyway the main issue is once i hit about 30 mph it beeps display says oil and it shuts down to idle once i release the throttle i can hit it again and can ride for sometimes the rest of the day sometimes it does it again as sson as i hit 30 the oil level is good and the oil is fresh im stumped thanks in advance for your help


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by drallab View Post
    new to the site but ive read it for awhile so i know you guys are the ones to come to with an issue. as soon as i connect the key it beeps and the display says sensor maybe unrealated to the issue but i figured id throw it in anyway the main issue is once i hit about 30 mph it beeps display says oil and it shuts down to idle once i release the throttle i can hit it again and can ride for sometimes the rest of the day sometimes it does it again as sson as i hit 30 the oil level is good and the oil is fresh im stumped thanks in advance for your help

    The "sensor" issue will need to be removed by a dealer's BUDS program. Next time it beeps, and the red light flashes, press the set button 5 times to see the trouble code, write it down, and let us know.

    Could also need a new oil press switch located under the intake manifold, near the throttle body, with one blue wire going to it.

  3. #3
    cool i had no clue i could pull the code!! im kinda scared to ride it since the warning beep is so random im afraid to damage it thanks for the help

  4. #4
    ok so i finally got it back into the water today rode around for about 15 mins before it beeped i pressed set 5 times and all it said was end WTF this is frustrating lol i now turn it over to the limitless knowledge of the forums

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 rxp issues ?'s
    By jersey785 in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-13-2012, 11:50 AM
  2. 04 RXP issues
    By danny3535 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-24-2012, 06:19 PM
  3. 04' RXP Issue
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-27-2009, 11:30 AM
  4. More Issues with my 04 RXP
    By 04RXP22 in forum 4-Tec Performance
    Replies: 23
    Last Post: 04-20-2008, 09:13 AM
  5. 04 RXP issues. Need helpful info.
    By 04RXP22 in forum 4-Tec Performance
    Replies: 33
    Last Post: 04-04-2008, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •