Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321

    750 fuji holed piston

    Had a problem with a 750 fuji motor, had holed P.T.O piston. replaced piston & rings. Also rebuilt complete fuel sys.mikuni 3 outlet fuel pump, hoses, pick up tubes, water seperator, new o-ring on fuel selecter,fuel restrictor on return line, rebuilt carbs with genuine mikuni kits. Got about 6.5 hrs on motor before it holed the MAG piston way lean, I dont think I was getting any adjustment on low speed adjuster on that carb. & cyl. I have a piston & rings that Im going to go back together with , But Im at a loss as where to start looking for the lean cond. problem. Any thoughts or ideas would be greatly appreciated.
    Thanks Brian


  2. #2
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698
    Did you use new carb gaskets? Did you do a leakdown test after the rebuild?

  3. #3
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    Yup new gaskets all the way around, Was able to get the leakdown to hold at 9 psi

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    First check your crank index, second what was your fuel pressure at idle and at WOT?
    Did you test your pop off and what was it set at?
    I get very leary of a repair to the fuel selsctor knob, I think it should be replaced with a new Bombardier unit.
    Any mods to the engine that would require larger jetting??

  5. #5
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    Crank index was fine, Did not check fuel pressure at either throttle setting. I assumed the new mikuni fuel pump was working correctly,Pop off was pto.18 cen.18 mag was 22. I did have a problem with the fuel selector knob, it was sucking air, after replacing o-ring there were no air bubbles in fuel line, Once again I assumed it was correct No engine mods, stock engine
    Thanks Brian

  6. #6
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    [QUOTE=blegan;1495279] Got about 6.5 hrs on motor before it holed the MAG piston way lean, I dont think I was getting any adjustment on low speed adjuster on that carb. & cyl.

    what makes you think you werent getting any adjustment on that low speed settng on that mag carb? was the motor shaking when you were trying to tune the lows? it will vibrate if its not getting enough fuel in that carb because the motor isnt running on all 3 cylinders.

    have ya checked the low screw for being bent or broken off or worn? just asking..... maybe a pece of something got caught up in there.

  7. #7
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    That was an idea I had also, to check adjuster screw next time I have the cover off the boat!

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Is the restrictor in place? If not, you won't have good fuel pressure.

  9. #9
    thester71's Avatar
    Join Date
    Jun 2009
    Location
    central ma.
    Posts
    1,698
    Isn't there o rings for the adjusters in a mikuni rebuild kit?

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Yes

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 750 Fuji cylinder head and piston combo $1
    By caliburst in forum Polaris Classifieds
    Replies: 3
    Last Post: 09-23-2013, 09:28 AM
  2. do i need to split cases in polaris slt 750 with hole in first piston
    By Bmwcrazyman in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-03-2013, 07:50 AM
  3. WTB 750 fuji piston
    By blegan in forum Polaris Classifieds
    Replies: 0
    Last Post: 07-05-2010, 02:54 PM
  4. 750 fuji piston markings
    By blegan in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-01-2010, 01:47 AM
  5. Slt 750 Burning Holes In Front Piston
    By 2sl750 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-17-2007, 02:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •