Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3

    Omg the ski from hell please help

    I built my brother in law a ski. Here's the problem....
    When you first run it for about 10 min its fine rpm's..
    After that it slowly drops rpm's and spits and sputters at 7800..
    Then as it gets hotter the rpm's drop more and more till about 6800.
    It still spits and sputters at those rpm's. I have changed everything imaginable and cant figure it out. Please help


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    cylinder wall to piston clearance too tight?

  3. #3
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Pump bearings?

  4. #4
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    new pump bearings

  5. #5
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    stock standard engine. 130 psi across board when hot

  6. #6

    Join Date
    Jul 2006
    Location
    Beaufort, SC
    Posts
    592
    needs a black magic header to get the exhaust out the head

  7. #7
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Is the flex-joint on the J pipe good.

    If it leaks, the zorst gasses gradually choke the engine.

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Could be exhaust leak. Does it run the same with the seat off?

  9. #9
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Its got to be mechanical, or something the sensors cannot monitor, or the bells would be ringing.

    One of them Odd-ball probs, so no matter how strange it may appear, it could be it.

    Std ski?

  10. #10
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Maybe plugged up fuel tank vent. Could try cracking open the filler cap to test.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First Ski = 05 STXR - Please Help with Questions
    By BadBowtie03 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-12-2010, 06:15 PM
  2. Took the ski out today Need help
    By cmher18 in forum 4-Tec Performance
    Replies: 22
    Last Post: 04-05-2010, 08:36 AM
  3. Took the ski out today Need help
    By cmher18 in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-03-2010, 11:14 PM
  4. WTB R&D 3rd vein intake from pro785, please help!
    By 96sltx1050 in forum Polaris Classifieds
    Replies: 2
    Last Post: 10-05-2009, 09:42 AM
  5. 2000 gp1200r Werid noise ski runs POOR please help
    By 00gp1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-06-2009, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •