Results 1 to 4 of 4
  1. #1

    94 sl750 not gaining any speed!

    Hi I have a 94 sl750 I took it out this last weekend for the first time this year, it wouldn't accelerate I put it back on the trailer and found it was spraying fuel out of one of the throttle bodies. My dad thinks it could be the reed valves, does this sound right or what else should I check? your help will be appreciated.


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    A little mist is normal, ALOT of fuel would be bad reeds.

  3. #3
    it is more on the alot side than a little mist, thanks I was thinking it was the reeds.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Go through your carbs if you haven't already while you have them off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 Sl750 not cranking, what to try next?
    By classic1275cc in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 08-19-2016, 07:27 AM
  2. R&D grate and plate, any speed gain?
    By emilbolboaca in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 03-19-2010, 09:31 PM
  3. riva water box any speed gains
    By seadoo rxt in forum 4-Tec Performance
    Replies: 2
    Last Post: 12-01-2008, 02:09 PM
  4. i have a 94 sl750 forsale not runing
    By bolsoforever in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-31-2008, 12:01 PM
  5. any speed gain on less tail cone on RXP?
    By XRIDER in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-17-2007, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •