Results 1 to 9 of 9
  1. #1

    SL750 low power help!

    I have a 94 Sl 750 that was running great until today. I let a friend ride it for a bit and he said that it was only running on 2 Cly. I thought it was just a fouled plug no biggie. Replaced all the plugs and check for spark all good, runs on the hose great. I lunched it today and it will take forever to get up to 20mph and is running ruff. I pulled it out and check the basics (fuel in the tank,water in the fuel, clogged filter, spark, ect.) and no luck.
    Anyone want to point me in a drection to get back up to par?


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Check compression

    Search for "Piston Wash"
    Search for "Reading Plugs"
    get a small flashlight and look into the spark plug holes

    1) You leaned a hole in the mag (front) piston
    2) one at a time pull a spark plug boot and see if it starts on just the other two cylinders. that will tell you which is dead

  3. #3
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    Also check pump area, you might have sucked something up

  4. #4
    Yea I Checked the inlet of the pump looks all good I'll have to pull the plugs and take a look at the pistons thanks

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk.

    You'll find letting friends ride your ski will always lead to problems.

    Ask if he flipped the ski over at all?

    If so, did he correct it in the right direction? These skis must be righted in one direction, or it will get water inside the engine.

    Might as well do a crank index test while you're at it.

  6. #6
    Well, looks like its a top end rebuild. Also need to score a new head. I'll post pic's later.
    Anyone recommend place to order parts? New head too?

  7. #7
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    cant be just a head. we look forward to the pics.. did you break a piston crown, hole the piston>>>>

  8. #8

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Wow, that's horrible.....

    You'd better make sure you get all the debris out of the bottom end, including crank bearings.

    And rebuild those carbs. Doesn't look like those hose clamps have ever been off since the factory installed them 15 years ago.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SL750 low power
    By woodeye in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-19-2009, 04:41 PM
  2. 95 SL750 low power
    By woodeye in forum Polaris Open Discussion
    Replies: 18
    Last Post: 06-16-2009, 09:48 AM
  3. 1996 polaris slt 780 intermitant hesitation and low power,any ideas?
    By Fraser327 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-02-2007, 06:10 PM
  4. Stumped on low power
    By Demetri4 in forum Polaris PWC Performance
    Replies: 19
    Last Post: 07-10-2007, 08:43 AM
  5. very high rpm low speeds, help
    By JCM in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-25-2006, 12:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •