Results 1 to 4 of 4
  1. #1
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1

    Stator & Mag cup

    From what I've read and what's been posted on my threads, I pulled the mag cover to have a look. There is some metal shaving in the mag cup, not much! Probably enough to eat some rectifiers. I guess any metal will cause a problem. What is the best method of cleaning the mag and stator? Since the mag is a magnet and of course the metal sticks to it. I want to get all the metal shaving off. How should I clean the stator? How do you test the stator when its off the ski?




  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by olds72 View Post
    From what I've read and what's been posted on my threads, I pulled the mag cover to have a look. There is some metal shaving in the mag cup, not much! Probably enough to eat some rectifiers. I guess any metal will cause a problem. What is the best method of cleaning the mag and stator? Since the mag is a magnet and of course the metal sticks to it. I want to get all the metal shaving off. How should I clean the stator? How do you test the stator when its off the ski?




    Bro , there is a thread that 96xpss chimed in on with regards to the stator and cup. It has great pics and they look just like yours. http://www.greenhulk.net/forums/showthread.php?104284-Check-out-these-pics-of-my-old-rectifier!/page4&highlight=Rectifier IMO you need to replace that stator. Looks like it got hot from shorting out. All that brown orange discoloration is the sign. Hopefully it hasn't taken out that new rectifier. Check our your flywheel and bendix gear real well. From what I've read they are the most common sources for the metal shavings. You will probably need to pull the cup so as to make sure you clean the entire area. You have to get ALL the metal shavings out.

  3. #3
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    I'll put some better pics of the stator up. I think the rectifier is gone. I ordered a new one. It's only showing 13.5 Vdc revving or not.

  4. #4
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts for sale 07-08 seadoo rxp stator and mag cup
    By XP537 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-20-2013, 03:42 AM
  2. Fs: 787 stator and mag cover
    By gorilla03 in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 07-27-2009, 11:10 AM
  3. 98' mag cup on 99'+ flywheel
    By fit4lyph in forum 2-Stroke Performance
    Replies: 11
    Last Post: 07-22-2009, 12:28 PM
  4. 96 XP mag cup bolts
    By merfturtle in forum 2-Stroke Performance
    Replies: 15
    Last Post: 04-28-2008, 10:22 PM
  5. Mag cup on a 947 Seadoo XPL
    By carbuff91 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 04-01-2007, 10:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •