Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41
  1. #1
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438

    Busted clutch question

    Hi everyone,

    I blew my clutch today . Had to limp the ski home at 5000 rpm.
    Got a theory as to why it blew just want your imput as if my thinking is correct. Its a long post but please read and add any imput if you can guys.

    Its got all the Riva stage 1 kit, Watson blow-off valve, ETss low boost wheel 13.5 psi at 8400 and 11.7 at 7700, ntercooler upgrade kit, Motec ECU.13/23 skat.

    I first put all the mods on before I got the Motec and the ski ran really hard on the stock limiter for a few rides and was poping loudly. Once I fitted the Motec and repitched my prop to stay just off the limiter the poping sound has stoped.

    I have only put 1 hrs on the motec and the clutch went out today. I am carefull not to hold full throttle for too long and to release it smoothly and when in choppy water not to work it too hard. You can hear the blow-off valve doing its job when you get off the throttle or going through chop.

    Could I have already caused the damage from riding the ski for 5 hrs with all the mods and the stock ECU and could the clutch have worn out by bouncing the ski hard of the stock limiter when full throttle?

    I hope this is what did it to the clutch and now I have the ski with higher limiter and prop pitched to stay of it that the blow-off valve will protect the new clutch.

    When it was boumcing savagly off the stock limiter the ski was poping loudly from the back but the blow-off valve was not dumping pressure, so my thnking is that this was causing high loads to the sprag clutch causing excessive wear.

    Is this thinking correct?

    Cheers everyone.


  2. #2
    Awamori's Avatar
    Join Date
    Aug 2008
    Location
    Okinawa Japan
    Posts
    275
    +1
    1
    You're on point...but before you go buying a new sprag look into the supercharger and find the root cause. I bought a sprag when in fact I broke a supercharger shaft. All I can say is hopefully its the sprag bearing and not the gear breaking like my situation or you will be looking at big money to ensure your motor is good to go. Keep us posted and don't buy anything until the root cause is explored.

  3. #3
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Quote Originally Posted by Awamori View Post
    You're on point...but before you go buying a new sprag look into the supercharger and find the root cause. I bought a sprag when in fact I broke a supercharger shaft. All I can say is hopefully its the sprag bearing and not the gear breaking like my situation or you will be looking at big money to ensure your motor is good to go. Keep us posted and don't buy anything until the root cause is explored.
    Will be pulling it down next week, hopefully its only the clutch.
    The first 20 hrs from new on this ski the mechanic had only put in synthetic oil in and I have since found out that it is no good for these sprag bearings.
    I put in the genuine yamalube and filter when I fitted the Motec 2hrs ago.
    Maybe the synthetic caused the sprag wear?

    I am sure its the clutch as when we first went for the ride today I noticed on hard acceleration it would start boosting hard and when it got to about 7400 rpm I noticed for say a second that it would hesitate then it would boost hard upto say 8400 rpm. It did this on a couple of full throttle hits today and on other accceleration hits would perform hard and good.
    On a full throttle run back home when I got of the power and went to accelerate again thats when I noticed no boost and max of 5500rpm.
    Its kinda like the clutch was on the way out today for say 2 hrs till it finally went.
    Hopefully its not what happened to you with the shaft and I won't have to kill the mechanic who initially commisioned this ski.

  4. #4
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Who said you cannot use synthetic oil???

  5. #5
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137
    Quote Originally Posted by SHOBiz View Post
    Who said you cannot use synthetic oil???
    +1 ?

    There was a long discussion on the forum about the oil being the root cause. Not so. The general answer is that no matter what oil ( I have used synthetic for 20+ hrs), or mods you have, your clutch will fail. Just a matter of when. Some with 10hrs, some with 40hrs, some have gone more.

  6. #6
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Quote Originally Posted by maxadrenaline View Post
    +1 ?

    There was a long discussion on the forum about the oil being the root cause. Not so. The general answer is that no matter what oil ( I have used synthetic for 20+ hrs), or mods you have, your clutch will fail. Just a matter of when. Some with 10hrs, some with 40hrs, some have gone more.
    I just read somewhere that 2fast4u mentioned this. Another Yammy mechanic also told me the same.
    I think we willnever know and the real problem is these clutches are just shit.
    Hopefully someone comes out with a better one real soon otherwise these skis are more useless than any other.

  7. #7
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by coldspace View Post
    I just read somewhere that 2fast4u mentioned this. Another Yammy mechanic also told me the same.
    I think we willnever know and the real problem is these clutches are just shit.
    Hopefully someone comes out with a better one real soon otherwise these skis are more useless than any other.

    I used Amsoil Synthetic for over 160 hours with the same original factory clutch and had some of the fastest speeds publicly provided from 2008 and 2009 (rebuilding motor in 2010).

    .02

  8. #8
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    I must have had a Friday afternoon built unit.
    22hrs is not good. I will try another and if it fails the ski will be sold.
    Maybe my surf jumping did it no good.

  9. #9
    coldspace's Avatar
    Join Date
    Feb 2009
    Location
    Brisbane, Australia
    Posts
    438
    Does anyone know if Yamaha is coming out with a better replacement real soon?

  10. #10
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by coldspace View Post
    Does anyone know if Yamaha is coming out with a better replacement real soon?
    Rumors, but only applies to stock really.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another SC clutch question.
    By 01xdime in forum 4-Tec Performance
    Replies: 5
    Last Post: 12-04-2006, 01:45 AM
  2. 05 RXP SC clutch question
    By orange71rt in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-28-2006, 09:38 AM
  3. Clutch question
    By Top banana in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-07-2006, 02:17 PM
  4. Clutch question, I think it went? help
    By Griff350 in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-08-2006, 06:20 PM
  5. Supercharger clutch question
    By orange71rt in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-10-2005, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •