Results 1 to 1 of 1
  1. #1

    Join Date
    Aug 2007
    Location
    Port Saint Lucie Florida
    Posts
    77
    +1
    1

    Question overheating and loss of power problems

    Ok well the kids came home last night and we took the skis to the beach today the B1 blaster (701cc) did ok at first and my son differently likes it but didn't seem to have as much power as the 650 vxrs after awhile it started to lose even more power and would just barely get up on plain it is getting cooling water and has oil dripping down the inside of the carb so I am thinking the problem must be that B pipe . The outside fiberglass part of the ski is getting pretty hot to the touch and the hoses are very hot .

    at this point If I had a spare stock exhaust I would just throw it on there but I don't was thinking about trying this other pipe do you thing it would make any difference or do you have any other ideas why it is overheating and losing power

    Oh ya does anyone know the correct water connection for the pictured protec pipe?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Protec pipe 2.JPG 
Views:	44 
Size:	244.1 KB 
ID:	205843  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 FX HO Cruiser -- A Perplexing Overheat Indicator and Lack of Power Problem
    By demetri in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-23-2014, 08:47 AM
  2. 2012 RXP X rpm jumping and loss of power
    By Ljpviper in forum 4-Tec Performance
    Replies: 18
    Last Post: 06-03-2013, 08:44 AM
  3. just bought a 550 and there is salt water build up in the head??? and loss of power..
    By dirtydave916 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-21-2011, 11:30 PM
  4. leaking rave valves and loss of power
    By juggaloXPracer in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-13-2010, 09:08 AM
  5. Overheating and loss of power on 2001 Virage TX
    By bruce0429 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-14-2009, 02:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •