Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1

    1994 waveraider 48mph!!! help!!! 150 compression, rive red pipe!! ocean pro f/a!! WTF

    Hi all, i just picked up this 1994 purple hull waveraider. The ski has great compression at 150 in each, and has the riva red pipe exhaust which claims the ski will run 57.8 with the pipe installed.ocean pro vortex f/a, the ski also has a pro tec intake and ride plate, and a riva extended steering nozzel.
    I took it out for the first time today and it only ran 48 mph!!!!! Stock it should run 53 mph!!!! It felt like it wasnt reving up all the way on top end, could this be a impeller problem, or bearing prob??? I didnt hear any noise .. Any help is appreciated, thanks


  2. #2

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    ANYONE???

  3. #3

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1

    Please help!!! 94 waveraider only doing 48mph with a riva red pipe!!!!!!!!!!!!

    I DONT KNOW WHATS WRONG PLEASE GIVE ME SOME HELP, THE SKI HAS 150 COMP, IN BOTH CYLINDERS, STARTS RIGHT UP, WILL NOT GO PAST 48 MPH!!!!!!!

  4. #4
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060
    Not really sure what is could be... my understanding is that the 1994 Waveraiders are the 701 two stroke motor. Very reliable engine. About 75-80 hp stock.

    You should be looking at around 50 mph stock.

    What RPM are you running? How did you check speed (GPS or Speedo)?

    You are going to need to give more information.

  5. #5

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    i checked the speed with a gps, 48.7 mph. top!!!! stock should get 53mph, and this ski has the riva red pipe, that claims with just the pipe it should run 57 mph. i dont have an aftermarket tach and the one on the ski is broken. but it feels sluggish on the bottom end and doesnt have the punch i think it should have, but falls on its face on top end, just doesnt seem to rev out all the way,

  6. #6
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    almost 50 for a 2 cylinder is good get a tach and report back with your rpms just because riva claims that for the ski doesnt mean anything riva claims all kind of speed for there packages.

  7. #7
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Stock the 94's will easily run 53-54mph.....what's up with the pump...if your making power...then it's something in the pump/rideplate/intake grate. Inspect the wear ring ...what's the clearances look like? You also need to get a good tach which will quickly point out if if your engine is making power. I had the MOD pipe on mine and the stock head milled, solas I prop, taper bored carbs, dual cooling and ran 58 and some change

    M

  8. #8

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1

    thanks for your replies

    the ski has a pro tec inteke grate and ride plate, MIKE P, I WAS THINKING THE SAME THING!!! ITS EITHER THE WEAR RING AND PROP, OR THE REEDS, I THINK, IM GONNA START MESSING WITH IT TONIGHT OR TOMORROW, . HOW MUCH ARE THE TACH'S AND ARE THEY EASY TO INSTALL??? THE SKI SEEMS TO BE HOLDING BACK, AND WHEN I WOULD TURN HARD IT WOULD FALL ON ITS FACE AND BOG... OH YEAH AND 50 MPH IS FREAT IF YOUR ON A KAWI 700 BUT NOT A WAVERAIDER!!!!!!! LMAO!!! WITH THIS SET UP I WONT SETTLE FOR ANYTHING LESS THAN 55MPH BUT IT SHOULD GET 56-57

  9. #9

    Join Date
    Jul 2010
    Location
    MIAMI, FL
    Posts
    411
    +1
    1
    freAT!!!! LOL I MEANT GREAT!!!

  10. #10

    Join Date
    Jun 2008
    Location
    Lake Conroe (Montgomery,) Texas
    Posts
    417
    +1
    10
    Quote Originally Posted by o uncola o View Post
    Not really sure what is could be... my understanding is that the 1994 Waveraiders are the 701 two stroke motor. Very reliable engine. About 75-80 hp stock.

    You should be looking at around 50 mph stock.


    What RPM are you running? How did you check speed (GPS or Speedo)?

    You are going to need to give more information.
    posted by zx11rider,
    almost 50 for a 2 cylinder is good...
    Guys, I don't want to sound too harsh or accusatory (is that a word?) but you guys really aren't familiar with the performance of properly running 1994 WaveRaiders. Take it from someone who has owned one since it was brand new. Mine GPSed 53.2mph 100% completely stock on decent water. Two yrs ago, I lost the stock rideplate because I forgot to tighten the bolts . Now I've got a Pro-Tec rideplate. About 4 weeks ago, I got 54.7 on GPS on outstanding water! My opinion is that the water conditions made the difference but maybe the plate helped. I don't know.

    I've still got some PWC mags from 1994. The Raider was voted "watercraft of the year" for whatever that's worth. One magazine radar tested the Raider at 55mph. I was sold!

    The stock, 701cc 1994 purple hull Raider has 80hp .

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 waveraider dieseling
    By jeeprunnr in forum Yamaha Old School Skis
    Replies: 14
    Last Post: 05-04-2015, 03:21 PM
  2. Replies: 0
    Last Post: 11-04-2010, 11:18 PM
  3. 1994 waveraider questions
    By jetskier90 in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 06-17-2007, 01:14 AM
  4. 1994 Polaris 750 Help ASAP
    By sgshore in forum Polaris PWC Performance
    Replies: 6
    Last Post: 04-15-2007, 11:13 PM
  5. 1994 waveraider stalled is it the low speed screw?
    By jeeprunnr in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 12-31-2006, 04:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •