Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    05 rxt died while riding, no codes

    While riding with my son today, the doo died while riding at 7000 rpms. I tried pulling codes, but nothing came up, just said end. When i tried to restart, it sounds like its not turning over right. The last time my ski sounded like this, they rebuilt the motor. I only have 80 hours on it, less then 10 since the top end was rebuilt from a sinking. any ideas? The rebuild was from jet trendz, so i know he did it right.


  2. #2
    mudbug660's Avatar
    Join Date
    May 2010
    Location
    Lafayette, La
    Posts
    57
    Sounds like the timing chain snapped. You probably bent up the valves pretty good too.

  3. #3
    I knew it wasnt good. Nothing about these have ever been good.

  4. #4
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    take out the plugs and check for compression. if one of the plugs is not coming out easy then you probably dropped a valve. if you have all the plugs out and its cranking over slow then it could be a seized supercharger or pump

  5. #5
    only two plugs will come out, and cylinders are filled with coolant.

  6. #6
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    sounds like you dropped a valve. but thats odd. 05 are known to have weak exhaust valves but if your saying you had the top end rebuilt then the valves should have been replaced with the updated ones

  7. #7
    over the winter, the ski took on a lot of salt water, so the mechanic replaced the top end, I dont know what that entails, i guess i could try to find the paperwork. It only has about 7 hours since then.

  8. #8
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    well if he didnt change the valves then the water caused the exhaust valves to rust and then you broke one. whenever i have a customer who sank an 04 or 05 i fog the shit out of the motor to prevent this from happening

  9. #9
    would that cause the coolant to fill all cylinders?

  10. #10
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    When it dropped the valve it could cracked a cylinder sleeve letting coolant in.

    Adding: All cylinders seems a little odd.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 polaris virage, died while riding & wont restart
    By burke in forum Polaris PWC Performance
    Replies: 5
    Last Post: 03-30-2017, 10:02 AM
  2. 05 RXT Dies Every 15 Seconds
    By jtrippttu in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-28-2014, 06:00 PM
  3. 05 rxt just died on the water and now no beep, no nothing
    By ou812 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-22-2013, 08:57 AM
  4. 2002 Genesis I - Running great, died while riding, now wont start
    By yismxplusb in forum Polaris Open Discussion
    Replies: 9
    Last Post: 04-02-2011, 09:26 AM
  5. virage 2002 800 dies while ridings
    By ratmuff in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-16-2008, 08:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •