Results 1 to 8 of 8
  1. #1

    Unhappy Help!!! 2005 rxt loud growling noise

    When i started it there is a very loud growling noise, sounds like its coming from the pump or drive shaft area. any help would be greatly appreicated.


  2. #2

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23
    Is this in or out of the water...I had the same issue with my 2005 RXT... Found its the carbon seal.. If it gets warm it will cause this to happen out of the water on the hose...You can't run it long out of the water or it will heat up. iF If you watch it with the cover off you can see the carbon seal boot vibrating causing the noise....

  3. #3
    nestbolt,
    Thanks for the reply, it was out of the water when i started it for the first time this year shut it off as soon as i heard it . I didn't see any water in the hull last year so i didn't think it was the seal. I still have the ceramic washers in so thats where my mind went, so i started it back up and felt the noise was coming from below the s/c. Did you change the seal yourself? if so how hard was it. also do you still have the ceramic washers in?

  4. #4
    DallasGV's Avatar
    Join Date
    Feb 2010
    Location
    Dallas, TX
    Posts
    168
    +1
    1
    You will hear this from many others - change out your ceramic washers before you do anything else.

  5. #5
    I recently had the same symptom. Mine made a bunch of noise while flushing it and thought my supercharger was howling despite a fresh rebuild. Turned out that the prop bearing in the pump was starting to eat itself. Pretty easy to check and I was very relieved it was that and not my SC.

  6. #6

    Join Date
    Sep 2009
    Location
    Lafayette,La
    Posts
    23
    Quote Originally Posted by greendoo View Post
    nestbolt,
    Thanks for the reply, it was out of the water when i started it for the first time this year shut it off as soon as i heard it . I didn't see any water in the hull last year so i didn't think it was the seal. I still have the ceramic washers in so thats where my mind went, so i started it back up and felt the noise was coming from below the s/c. Did you change the seal yourself? if so how hard was it. also do you still have the ceramic washers in?
    My seal was not bad it just gets hot when running out of the water. The noise was because the seal was getting hot. I sprayed water into the seal from under the ski and it stopped. I removed my drive shaft and inspected the seal. Also I cleaned the corrosion off my driveshaft before reinstalling the seal. I just make sure I only run it 3 min or so out of the water on the hose..Replace those washers!!

  7. #7
    mine wasn't hot it did it right when i started it. took the pump off and when i spin it it's not that smooth but the grease looks good.

    combatcraig,
    was your bearing obvious or how did you know it was eating it's self?

  8. #8
    When it happened on the water I wasn't 100% sure what it was. It was just loud as heck and started to vibrate so I shut it off and got towed back to the dock. When I pulled off the pump and spun the prop, it was not smooth and would even bind at times. So I pulled the cone on the back (only 3 screws) most of the grease was gone and I could see the race was chewed up and some ball bearings even fell out! Some were oblong etc. I knew that was the problem and am waiting for my parts as i type this. I was so happy my SC wasn't the issue. Hope you have the same luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 07-15-2013, 07:53 PM
  2. 2005 RXT help....
    By nestbolt in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-01-2010, 08:48 AM
  3. 2005 RXT pictures (SC ingestion) - Help
    By rev114 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-12-2009, 08:48 PM
  4. 2005 RXT in Florida **Help Please **
    By rev114 in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-19-2008, 09:36 PM
  5. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •