Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

    04-05 ECU on an 06?

    The other day I installed a riva 04 ECU on my 06 electrics and it powered up everything. the only code was oil PSI because the 06+ uses and NC switch and the 04-05 uses a NO switch. if I change to the NO switch will the ECU work? or are there any other sensors that are different?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Why not just unplug the oil pressure switch, so that it's N/O... and go run the ski to see if everything else works properly

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    I dont think my stand will float.
    Click image for larger version. 

Name:	d5285f4f.jpg 
Views:	169 
Size:	297.7 KB 
ID:	206555

  5. #5
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    Quote Originally Posted by beerdart View Post
    I dont think my stand will float.
    Click image for larger version. 

Name:	d5285f4f.jpg 
Views:	169 
Size:	297.7 KB 
ID:	206555
    Yeah u might want to add a bunch of foam to it! Or some life jackets!

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by beerdart View Post
    I dont think my stand will float.

  7. #7
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Grey OPS goes with this set of electronics.

    Oh, and a bit more buoyancy would certainly help.

    How do you steer it?

  8. #8
    on my 06 ski i plugged an 05 ecu and it start at first ....BUT i used the injectors harness part from an 05 and the extra two sensors ....no errors....next wekeend iŽll try on water

  9. #9
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    FLoatings not the problem! Theres no pump... Duh

  10. #10
    hi guys
    today i took a ride on my 2006 ski w/ a rotax ECU 2005 at 8550 rpm and only error code was p1202 it meens the tank oil sensor.....i must look for a resistor to plug in...very good for those people who as skis 2006/7/8...and have a 2005 ecu on the box

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05-electrics work on an 06 engine?
    By Insanediego Joe in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-18-2010, 08:46 PM
  2. 05 sponsons on an 04
    By addicted in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-22-2008, 06:42 PM
  3. Advantage of 05 sponsons on an 04 RXP?
    By snowrunner in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-13-2008, 10:20 PM
  4. Who has a 04-05 Manual on CD
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 42
    Last Post: 09-06-2007, 10:29 AM
  5. Upgrading clutch on an 06 after impeller install
    By excess in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-16-2006, 10:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •