Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2010
    Location
    Panama City Beach Fl
    Posts
    121

    Needs some help with ported 1390 blew up.....

    So I got a ported 1390 in my gpr. Well its been running perfect. So I took it out yesterday with fresh gas and mixed 40:1. Rode it for about 3 or 4 hours hard then let it sit. Took it out about 30 mins later and got 2 laps and I was coming around the last buoy making a hard left turn and the ski dies. So I tried to crank it back up and it would. So we drug it to the beach and it starts and was making a loud clunking noise. We pulled the plugs and number 1 was wet and black, number 2 was more of the white gray color and 3 was dry and white. So I know atleast number 3 is toast. This is my first EFI ski and was just looking for help as to what could have caused the problem. Its not cheap to fix since its got weisco piston in it..... Heres a list of mods. BTW this is Flyboys old ski.


    list of mods:
    Tim judge ported 87mm cylinders
    Lowel matched R&D single Heads, 162,162,157
    Wisco 87 mm Pistons
    trued and welded crank
    Ross Nemo stage 3 TBs
    Ruis Reed system, with new Pedals
    Riva EFI controller
    R&D Powervalve clips
    WaterWoody Modified 1300 Powervalves
    Carbon Fiber Tunnel reinforcement
    upgraded rideplate and pump shoe brackets
    upgraded driveshaft hose
    Riva Free Flow Exhaust
    Opened Riva D-plate
    Jet Works exhaust kit
    1200 Water box
    aftermarket handle bars
    TinyTach
    aftermarket seat cover
    aftermarket graphics
    painted fairings
    drycell battery
    impros DF 14/23 very good prop
    smooth cut R&D trim tabs
    modified R&D ride plate
    Modified Skegless ride plate
    Riva 1200 intake grate
    Sealed pump show
    Premix


  2. #2

    Join Date
    May 2010
    Location
    Panama City Beach Fl
    Posts
    121
    There has to be someone on here that can help me out...

  3. #3
    need pics

  4. #4
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    loud clunking noise.... sounds like the crank bearings let loose, tear the motor apart then post pictures how long did you hold it full throttle when it was running

  5. #5

    Join Date
    May 2010
    Location
    Panama City Beach Fl
    Posts
    121
    It was never held full throttle more them maybe 15-20 sec. The head is pitted and the cylinder walls scuffed up. Also the piston is toast.

  6. #6
    zx11rider's Avatar
    Join Date
    Jun 2009
    Location
    Cape Coral
    Posts
    1,132
    well you got one cylinder toasted is the crank tight on that bad cylinder

  7. #7
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    What is the controller set at?

  8. #8
    Quote Originally Posted by Topher03 View Post
    There has to be someone on here that can help me out...
    Yah....Flyboy...........

  9. #9
    banshee350racer's Avatar
    Join Date
    Oct 2008
    Location
    Mokena,IL
    Posts
    170
    +1
    1
    EFI controller Fail? maybe....

  10. #10

    Join Date
    May 2010
    Location
    Panama City Beach Fl
    Posts
    121
    I get those setting for you in a few

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need some help with minor hull repair
    By stingray152003 in forum Yamaha Open Discussion
    Replies: 15
    Last Post: 02-01-2008, 07:52 AM
  2. Need some help with gas valves
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 08-13-2007, 11:54 PM
  3. Need some help with a 650 LX
    By utahnewbie in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 05-04-2007, 11:59 PM
  4. I Need Some Help With My Shark !!!!!!
    By sleblanc in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-20-2006, 03:17 PM
  5. Need some help with adjust a thrust
    By AaronC in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-10-2006, 06:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •