Results 1 to 9 of 9
  1. #1

    96 GSX no hole shot power

    Hello,

    I have a 96 Seadoo GSX with the 787 motor. It has no hole shot power at all. I am pretty sure it is cavitation. I have installed a new impellor and wear ring. Siliconed the wear ring to the pump housing. Siliconed the ride plate based on other recommendations from folks on this site. The motor runs right up to 7200 rpm and you just sit there until it finally catches and takes off. Once it primes, it runs great. I have a 760 Yamaha Waveraider that pulls 10 times harder from take off. Any suggestions? I am looking to replace the drive shaft and the seal kit that goes into the hull next? Not sure what else I can do.


  2. #2

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    does that seal leak water? did you check your impellor/wear ring clearance? you should be smoking the 760.what intake grate do you have and is that sealed/lined up properly and is the shoe the sealed/lined up properly. see if you have any rotational play in the drive shaft @ the pto and impellor. where do you ride? i hate when i 785 under performs a yamaha!lol

  3. #3
    It does not leak inbound. That ski does not take on any water at all. The impellor was just purchased (stock) with the wear ring was from SBT. The old one had I think 1 millimeter clearance. The new one seemed very snug. I did not or haven’t checked with a feeler gauge since I installed it. I am running a stock grate that looks pretty beat up and or pitted. I have sealed everything with silicone so far. I am not sure what the process is to line them up with the shoe. I will have to research that. I did fire the engine the other day and looked at the drive shaft under idle and it seemed like it was not true. Almost like a wobble or out of round maybe. I did not know if that was from engine shake or if it is truely out of round. I hate to pull everything apart since I silicone it all together but I guess I will have to. I will look for a newer grate also. I agree that machine should pull like a freight train. With my wife and I riding it takes 15 sec to get on plane. Granted I am a larger than average but she is not.

  4. #4

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    you didn't mention that you ride 2 up and that you're a big guy. that hull will never have good take off in those conditions. whats the weight limit on that ski? try it with just one rider.

  5. #5
    Even with 1 rider the Yamaha blows it away. I ride them both and it is no comparison right now. By my self is is ok at best when I ride the Seadoo. I know it should do better. The motor is not working hard at all when it is sitting there trying to prime. Still takes 15 sec to plane out by my self. The Yamaha takes 3 sec to plane. Once it primes it runs great. Trying to pull a 360 it looses prime and I start all over trying to get on plane again. When I say larger than average I am talking 280 lbs by myself.

  6. #6

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    was it doing this before the new impellor and wear ring? do you know for sure that its the right impellor for your ski? did impros repitch it that you know of?

  7. #7
    It was really bad before I replaced the impeller and wear ring. It would barely plane by my self and would not plane at all with my wife on the back. The new wear ring made a huge difference. I don't know what the pitch was. I ordered a stock replacement refurb impeller from SBT.

  8. #8

    Join Date
    Sep 2009
    Location
    n.j.
    Posts
    457
    hmmmm, can you get a part number of it? i would call impros and speak to dave, maybe you can send him yours so he can check it.

  9. #9
    Can you send me a link to there web site or a contact number please? Or are you refering to SBT?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XLT 1200 No hole shot
    By Pipeman in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 06-03-2009, 08:45 AM
  2. fzr no hole shot
    By seadoo rxt in forum Yamaha PWC Performance (4-stroke)
    Replies: 29
    Last Post: 05-18-2009, 05:51 PM
  3. 96 GSX no Start!!! Lil Help
    By GSXRYDER in forum 2-Stroke Performance
    Replies: 15
    Last Post: 11-03-2008, 08:19 AM
  4. '96 speedster - poor hole shot
    By Cwannamaker in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 07-12-2007, 02:40 PM
  5. these gprs have no hole shot at standard
    By jetskibill9999 in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 03-02-2007, 01:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •