Results 1 to 2 of 2
  1. #1
    banshee350racer's Avatar
    Join Date
    Oct 2008
    Location
    Mokena,IL
    Posts
    170
    +1
    1

    intermediate shaft seal on bearing housing fail....

    Has anyone heard of that seal failing? Mine has a pin hole leak in it and it shoots grease everywhere the bearing is fine I just add grease every time I ride. Has anyone else experienced this before? this in on a 03 1300 with 120hrs


  2. #2
    1200Jet's Avatar
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    160
    +1
    6
    I had the seals go that protect the spline in the mid shaft, it destroyed the carrier splines and corroded a hole through the coupler. If its leaking where you say its a good idea to pull the pump off and inspect the shaft as well. But i'v never heard of that seal going, have you checked that the bolt are tight?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replacing the shaft seal on an '05 15F
    By JRINJAX in forum Kawasaki How To & FAQs
    Replies: 12
    Last Post: 05-01-2012, 02:35 PM
  2. how to change a impeller shaft seal on a vx 110 pto
    By KyleP in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 10-14-2011, 08:25 PM
  3. seal and bearing housing
    By gtown in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-21-2011, 11:14 AM
  4. green shaft seal on solas 15/22
    By Mike H in forum 4-Tec Performance
    Replies: 10
    Last Post: 11-03-2009, 05:22 PM
  5. WTB Intermediate shaft and Bearing housing
    By BadinGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-11-2009, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •