Results 1 to 4 of 4
  1. #1

    03 xpdi 950 bogs like a duck stuck in the mudd!

    so my brother just bought this 03 xpdi 950 and the first time we had it out you hit it and its like you got a 5hp briggs powerin the damn thing for about 100 to 200 yards then all of a sudden it will take off like a raped ape and stays pretty good till you turn hard and then it will do the same thing all over again, the dealer he bought it from is a harley dealer and when he tried to take it back they basicly told him to get bent, so now hes stuck with this thing that runs like hell ive seen you tube vids and it looks like an ass kickin machine when they run good, i thought maybe one of yall have ran into this before any help would be great! thanks


  2. #2
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by brickhousen View Post
    so my brother just bought this 03 xpdi 950 and the first time we had it out you hit it and its like you got a 5hp briggs powerin the damn thing for about 100 to 200 yards then all of a sudden it will take off like a raped ape and stays pretty good till you turn hard and then it will do the same thing all over again, the dealer he bought it from is a harley dealer and when he tried to take it back they basicly told him to get bent, so now hes stuck with this thing that runs like hell ive seen you tube vids and it looks like an ass kickin machine when they run good, i thought maybe one of yall have ran into this before any help would be great! thanks
    Replace plugs, they may look good but replace them. If i remember correctly my RXDI would go through a set each year.

    Check for bad gas, clogged fuel filter.

    Also do a search on how to clean the "rave Valves" on a 951 DI engine.

    hope this gets ya started.

    Ed

  3. #3
    Quote Originally Posted by 12timeworldchamps View Post
    Replace plugs, they may look good but replace them. If i remember correctly my RXDI would go through a set each year.

    Check for bad gas, clogged fuel filter.

    Also do a search on how to clean the "rave Valves" on a 951 DI engine.

    hope this gets ya started.

    Ed
    cleaned the rave valves, tried two sets of plugs that all helped but didnt fix the problem i havent checked the fuel filter yet where is it at on this thing? it seems like a fuel problem for sure could it be a sensor of some kind maybe?

  4. #4
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Maryland
    Posts
    445
    +1
    9
    Quote Originally Posted by brickhousen View Post
    cleaned the rave valves, tried two sets of plugs that all helped but didnt fix the problem i havent checked the fuel filter yet where is it at on this thing? it seems like a fuel problem for sure could it be a sensor of some kind maybe?
    It may be in the gas tank. I'm not sure though maybe someone can speak to this?

    Ed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Half a plastic nut stuck in the reverse cable fitting
    By Cusack in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 12-06-2014, 07:14 PM
  2. Gas can nozzle stuck in the gas tank.
    By tjdoyle999 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-11-2014, 12:06 PM
  3. Replies: 27
    Last Post: 08-02-2013, 10:54 AM
  4. How do you extract a prop shaft thats stuck in the pto splines????
    By spannerspencer in forum Polaris How To & FAQs
    Replies: 20
    Last Post: 01-11-2012, 12:58 AM
  5. WTB emergency stuck in the water!!! please help with 05 rxp !
    By bksbigboy69 in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 07-10-2011, 05:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •