Results 1 to 7 of 7
  1. #1
    idealrides's Avatar
    Join Date
    Oct 2008
    Location
    Caribbean
    Posts
    41

    starting up + throttle stuck at WOT + concrete = ouch

    Rider fell backwards into the water as it launched into the dock, luckily she wasn't injured. Mechanic found minor corrosion on the butterfly valve caused it to seize.





  2. #2
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Ouch..!!

    Always be ready to pull the pin, and tug the DESS key off.

    If nothing in front, then all easier, but facing a jetty, try to get reverse gate set-up part way to neutral.

    With wrong conditions, they can easily lurch forward.

    Should have been fogged/serviced/noticed at service times.

    Still, not nice, it is possibly one of those freak accidents that we hear of. Hope all ok though.

  3. #3
    wow that's nuts! hope everyone is okay. i'm wondering how quick they will get a new one, looks like they have money (bottom left hand corner of pic)

  4. #4
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    If the throttle is stuck wide open the ski wouldnt start cause of drown mode, also looks like the trailer is wrecked by the way the ski is sitting

  5. #5
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Good point.

    Guess the trailer was "Modded" to get the ski back on to it.

  6. #6
    rick xp's Avatar
    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    1,013
    +1
    7
    Stuff the ski take some more pics of that Ferrari 430 sitting there.

  7. #7
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Ya can't beat the sound of the Ferrari on full tilt aye?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 RXT-X throttle gets stuck at WOT!!!
    By HSCOOL in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-27-2014, 12:22 PM
  2. Replies: 4
    Last Post: 03-07-2011, 12:00 PM
  3. new throttle, now it redlines at start up?
    By sfackett0 in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-29-2009, 05:42 PM
  4. question on throttle bodies at WOT and IDLE
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-13-2008, 12:00 PM
  5. Video of my throttle postion at WOT
    By MIARider in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-05-2007, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •