Results 1 to 2 of 2
  1. #1

    SLT 750 gauges have no power

    It has been years since my gauges have worked, and one has decided to come loose, so I decided it would be a good time to finally fix them. Is there a battery for the gauges, or do they run off the main 12 V starter battery? I do not have manual so I could use some advice and maybe a contact of where I could get a digital copy of a manual if it is available. Thanks

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Welcome to the Hulk Curt.

    No internal battery. Uses the voltage from the magneto to charge the battery when running.

    Not sure if anyone has fixed a round MFD yet or not. But if the fuse is good (and you used an ohmeter to test it), it's most likely damaged and in need of replacement.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dead 2002 XLT800 - No power to gauges
    By scottbaty in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 05-24-2008, 10:56 AM
  2. New(old) slt 750
    By MetallikatZ3 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 08-25-2007, 12:14 AM
  3. 94 slt 750
    By keng in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 08-02-2007, 10:59 PM
  4. New to me 95 SLT 750
    By 95SLT750Rider in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-08-2007, 05:26 PM
  5. slt 750
    By 2springers26 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 06-29-2007, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts