Results 1 to 2 of 2
  1. #1

    SLT 750 gauges have no power

    It has been years since my gauges have worked, and one has decided to come loose, so I decided it would be a good time to finally fix them. Is there a battery for the gauges, or do they run off the main 12 V starter battery? I do not have manual so I could use some advice and maybe a contact of where I could get a digital copy of a manual if it is available. Thanks
    Curt


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Welcome to the Hulk Curt.

    No internal battery. Uses the voltage from the magneto to charge the battery when running.

    Not sure if anyone has fixed a round MFD yet or not. But if the fuse is good (and you used an ohmeter to test it), it's most likely damaged and in need of replacement.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical issue with 94 slt 750 every thing stays powered up
    By BarelyFloatin in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 09-01-2013, 10:09 PM
  2. died at idle at the ramp and now i have no power???none???battery reads 12.6v???
    By 04gp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-28-2013, 10:30 PM
  3. 94 slt 750 help with no spark please
    By power1shop2 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-15-2010, 02:52 PM
  4. 780 SLT bogs off idle no power
    By rhislo in forum Polaris Open Discussion
    Replies: 16
    Last Post: 09-19-2007, 10:39 PM
  5. '94 SLT 750...deal or no?
    By Fish Man in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-22-2007, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •