Results 1 to 9 of 9
  1. #1

    Question 2006 Seadoo Rxp Engine,RPM Problem. Please Help!

    When I put the lanyard in it beeps twice then on long one. It idles fine, but when you go to take off out of the hole it falls on its face and feels like it is missing. If you play with the throttle it will get up on plane but is only going approximately 20-25mph. I do not have a learners key on it. When you take it out of the water it seems to run fine, I also changed the plugs today and on the hose it seems to run fine. Also my gage cluster is broken. Any ideas???
    Thanks


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Your running in limp mode for some reason (possibly a bad engine or exhaust temp sensor)... a working instrument cluster would tell you why! The long beep is an error that the cluster will show you... if you could read it.

  3. #3
    limp mode? It sure felt like whimp. How can I get out of whimp mode?

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by gotach View Post
    limp mode? It sure felt like whimp. How can I get out of whimp mode?
    Get an instrument cluster that works... so you can figure out the cause of the error, and fix the problem! Or you can take it to the dealer, and have them read the code with BUDS.

  5. #5
    The cluster is on its way. But I will have to go to the dealer for the cluster to be program right?

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by gotach View Post
    The cluster is on its way. But I will have to go to the dealer for the cluster to be program right?
    On an 06......... I can't remember I'm gonna say probably so... I know your hours are stored in the 06 cluster!

  7. #7
    Cool I will have a New 06. lol hey thanks for your info

  8. #8
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by gotach View Post
    Cool I will have a New 06
    That right there is exactly why I would never buy a used ski based on "stated" hours!

  9. #9
    Well I think it has about 30-35 hours on it. When I got the ski it had 20hrs on it and when the cluster when out it had 27hrs and I have had it out three times this summer. It was my cousins ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Seadoo RXP problem please help!!!
    By aaronrich17 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2016, 11:12 AM
  2. 04 rxp MPH GAGE PROBLEMS PLEASE HELP!!!
    By vicario62590 in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-12-2014, 01:42 PM
  3. RXP 2005 cluster problem. Please help!!
    By tocullo in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-01-2011, 08:58 PM
  4. 05 RXP LCD Display Problem, please help!!!
    By dathanas in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-28-2010, 07:40 PM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •