Results 1 to 8 of 8
  1. #1

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715

    can i run a 06 riva on 04 rxp

    can i run a 06 riva ecu on a 04?


  2. #2
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    I dont think so...

  3. #3
    Codeman666's Avatar
    Join Date
    Aug 2007
    Location
    sunny south florida
    Posts
    179
    +1
    8
    Someone on here just put a 04 riva on a 06 and said it worked except for the oil pressure sensor cause they were different. I don't know what would happen with a 06 on a 04 maybe you should find the guy and trade with him I forgot his name it was just a recent post

  4. #4

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    yea i saw that i guess ill try it if anyone knows please let me know

  5. #5
    Moderator Insanediego Joe's Avatar
    Join Date
    Mar 2006
    Location
    San Diego, California, United States
    Posts
    5,885
    +1
    142
    That guy is beerdart and the motor was sitting on a stand not in a ski in the water. I would proceed with a high degree of caution.

  6. #6

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    ok so i put it on it starts but check engine sign comes on also anykey will work

  7. #7
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    OPS & TOPS valve are different setups.

  8. #8

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    if i hook it up to the buds can i make it work does anyone really know about this, like i said before it starts up and sound perfect

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 dash on 04??
    By BOOSTED in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-27-2007, 11:05 PM
  2. How can I put OEM 05 sponsons on 04 RXP
    By rxp_boy in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-06-2007, 04:10 PM
  3. Killer deal on 04' RXP
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 10-24-2006, 01:25 PM
  4. Bad switch or starter problems on 04 RXP.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-22-2006, 12:53 PM
  5. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •