Results 1 to 2 of 2
  1. #1
    dnielsen's Avatar
    Join Date
    May 2008
    Shreveport, Louisiana

    Riva's new RRFPR, "POS"

    Installed yesterday, got home from a long day at work, hooked up the old water hose, fired it up, turned away for a split second to turn on the hose........,,, and WHAM, fuel spraying all out around the seal of that pretty Red, White, and Blue gauge, almost a vapor it was due to the pressure, then "POP", out comes the plastic lens with all that goop and fuel.......Damn!!,

    Simple little setup, easy to install, almost stupid proof (thats me)...

    What goes, anybody got any ideas????

    This is a PX, surely I havnt missed something maybe pertaining to the stock fuel pump pressures have I?

  2. #2
    Richieb's Avatar
    Join Date
    Oct 2008
    Sydney, Australia.
    Sounds like a faulty item to me.

    Return it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva's free flo exhuast "kit"
    By VaRedneck in forum 4-Tec Performance
    Replies: 29
    Last Post: 11-03-2007, 04:40 PM
  2. Replies: 21
    Last Post: 10-29-2007, 01:10 PM
  3. New "RIVA Super Washers" about to hit the market
    By Green Hulk in forum 4-Tec Performance
    Replies: 109
    Last Post: 06-21-2007, 11:32 AM
  4. The official "tips, tricks, timesavers, headache savers" thread
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-24-2006, 11:00 AM
  5. having fun with John Abbott PIC ""CONTEST"
    By Knr in forum Yamaha Open Discussion
    Replies: 16
    Last Post: 04-29-2006, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts