Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2010
    Location
    Charleston, SC
    Posts
    7

    Please somebody help

    I've got an 07 R12X with a serious issue. I've taken it to two different dealerships and neither one can seem to fix my problem. So far they've replaced the oil pressure sensor and the vacuum chamber. It seems to run stronger now but the initial problem still exists. Whenever I'm at full throttle for any amount of time safety mode kicks in and puts me to an idle speed with the warning light, beeper and FI light flashing. What is causing this problem? I can shut the ski down. Remove the key. Count to ten and restart it. It will then run fine but just as before. Does it need a rag in the gas tank. I've got a lighter! So far I've put 8 hrs on it myself. The two shops have accumlated about the same and I'm short $500 along with two payments. Not to mention an entire month of shop time. Summer's only so long. Help


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    What happens when you do this check?

    http://www.greenhulk.net/forums/show...heck-procedure

    Shawn

  3. #3
    Yeah I'm a coucher, and proud of it! ticketplease's Avatar
    Join Date
    Aug 2007
    Location
    On Lake Bistineau
    Posts
    73
    So what happened getinwet?

  4. #4

    Join Date
    Jul 2010
    Location
    Charleston, SC
    Posts
    7
    oo

  5. #5

    Join Date
    Jul 2010
    Location
    Charleston, SC
    Posts
    7
    Just read the post and tried it out. Seems to be operating correctly.

  6. #6
    JRINJAX's Avatar
    Join Date
    Oct 2007
    Location
    Jax, Florida
    Posts
    872
    +1
    1
    If the wgs is good, borrow someone's MacBoost Module and see if you still have the problem.

  7. #7

    Join Date
    Jul 2010
    Location
    Charleston, SC
    Posts
    7
    Wgs has been replaced and still having the same issues. What's a MacBoost Module? What would I do with it if I were to find one to borrow?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 3d di problem somebody help me please
    By monsoonmadness in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-04-2012, 12:50 AM
  2. Please send help s.o.s.
    By qwikki150 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-16-2009, 10:06 AM
  3. can somebody help??
    By 2006RXP in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-12-2009, 06:01 PM
  4. Gp1300r tick over but does not fire up. PLEASE anyone help me!
    By Waverider1300 in forum Yamaha How To & FAQs
    Replies: 16
    Last Post: 04-21-2009, 11:07 PM
  5. Can somebody help me with what this is on my leg.
    By HallPass in forum Open Discussion
    Replies: 76
    Last Post: 01-09-2009, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •