Results 1 to 9 of 9
  1. #1
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395

    Oil canister question... After having everything out

    The motor blew so while it was out I pulled fuel & oil canisters as well.


    Everythings all back in and lines are hooked up to correct locations.

    Both cranks case lines filled up with oil after filling oil canister to top.

    But the oil feed line to the oil pump never took in any oil. Is there a trick to it filling up? Or is it most likely clogged? I drained all the oil that was in it n it sat for a few months. Now it's full to the top w/ BRP synthetic


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by Stagesrt4 View Post
    The motor blew so while it was out I pulled fuel & oil canisters as well.


    Everythings all back in and lines are hooked up to correct locations.

    Both cranks case lines filled up with oil after filling oil canister to top.

    But the oil feed line to the oil pump never took in any oil. Is there a trick to it filling up? Or is it most likely clogged? I drained all the oil that was in it n it sat for a few months. Now it's full to the top w/ BRP synthetic

    Isn't there a bleed screw on the pump. You bleed till no more air comes out. The procedure is described in the manual.

  3. #3
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    Yea there should be the adjustment screw, I just assumed a little oil would trickle down the line...


    I just spent last 3 hours reading my manual. I'll install starter & arrester tomorrow then try to prime the system.

  4. #4
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    ok it all worked out


    oil eventually made its way down the oil feed line once i towed ski around...

    ski runs!!!

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    dude ive been looking at your avatar and am I seeing this correctly? 96XP with 97+ steering?

  6. #6
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    Sure is

    you no like?

    I can post more pics once I'm @ a computer

  7. #7
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    No I totally like it from the avatar pic! I may do that to my stocker...what pars are involved? just the bars and pad?

  8. #8
    been around the block Stagesrt4's Avatar
    Join Date
    Mar 2010
    Location
    S. elgin
    Posts
    395
    Just cover and pad....you just have to trim some of the white plastic on pad where it mounts to handlbars......you can reuse X4 handlebars...

    set it and forget it...ha...


    Click image for larger version. 

Name:	IMG_0226[1].jpg 
Views:	33 
Size:	73.7 KB 
ID:	207173

    Click image for larger version. 

Name:	IMG_0225[1].jpg 
Views:	33 
Size:	75.0 KB 
ID:	207174

    Click image for larger version. 

Name:	IMG_0224[1].jpg 
Views:	28 
Size:	90.5 KB 
ID:	207175

    Click image for larger version. 

Name:	IMG_0223[1].jpg 
Views:	36 
Size:	84.0 KB 
ID:	207176

  9. #9
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    sleek and simple...I like it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Parting out a 2000 genesis fuel injected ski.. Have everything!!
    By polarisjunky in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-17-2013, 08:06 PM
  2. vx110 guru question after eng rebuild does computer have to b reset
    By durdwood in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 10-05-2011, 04:39 PM
  3. Replies: 4
    Last Post: 11-24-2009, 05:25 PM
  4. question on ported 1300...idle surges after having water in engine...i
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-23-2009, 09:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •