Results 1 to 6 of 6
  1. #1

    How hard to change the hull seal?

    Has anyone ever had problems with this? I cant get anything to leak unless Im going down the lake. It feels the hull up FAST.....I cant find a water leak from a hose anywhere. I am taking everything out and replacing every water line. The seal is the only thing I can think of. Does this drive in from the pump side or the engine side???
    This GPR has been jinzed from the start.....


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Is your shoe sealed? Reinforcment? Thats a sign of the shoe pulling down. Are your speeds down? Also,have you checked the 1 1/2 hose from the mid wall to pump tunnel?

  3. #3
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11

  4. #4
    Quote Originally Posted by WATER WOODY View Post
    Is your shoe sealed? Reinforcment? Thats a sign of the shoe pulling down. Are your speeds down? Also,have you checked the 1 1/2 hose from the mid wall to pump tunnel?
    Speed are definatly down but its because water is getting into the carbs. The driveshaft is throwing it all around. This happens after about 2 minutes of idle time getting out of the no wake zone. The tunnel is reinforced but I will check the shoe.

    I really dont think that is the problem because the engine just will not run to its full potential...
    Ununsure about the hose will check....

  5. #5
    The rubber hose is ok. I pulled the pump and cant find any water seal between the hose and the pump. I guess the only seal is in the intermediate shaft?

  6. #6
    1200Jet's Avatar
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    160
    +1
    6
    I had a very simillar issue just recently, but I noticed mine when the carrier shaft spline let go. Water got in throught the carrier seals and corroded the splines and then a nice hole through the drive coupler. I'm guessing yours is the same but your shaft hasn't gone, YET.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 04-19-2015, 06:19 PM
  2. Bosch Injectors/How hard to pull the motor?
    By Envy in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-13-2011, 03:27 PM
  3. Replies: 3
    Last Post: 04-28-2011, 11:17 AM
  4. How Hard to Remove the Ride Plate.
    By yellow4 in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-19-2007, 10:51 PM
  5. how hard to change out electrical box
    By sic fish in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 07-08-2007, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •