Results 1 to 8 of 8
  1. #1
    ONELEGMAN not oenlegman
    Join Date
    Jan 2010
    Location
    austin texas
    Posts
    17

    rxp-x with new ecu lost rpm to 7500 HELP

    OK so I have a rxp-x with Intake, throw hull exhaust, riva intake grate, riva Reduction Nozzle and riva 8600 ecu with 50lb injectors ok well when I put the ecu on and took it out the rpm where around 8250 and ran about 78is after a cuple of day I took it on a long ride and over heated and killed my Thermostat so I put Open Loop Cooling kit on it and took it out and the rpm wont go over 7540 and dusent fell as pepy in the throdel now to it lags


  2. #2
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by oenlegman View Post
    OK so I have a rxp-x with Intake, throw hull exhaust, riva intake grate, riva Reduction Nozzle and riva 8600 ecu with 50lb injectors ok well when I put the ecu on and took it out the rpm where around 8250 and ran about 78is after a cuple of day I took it on a long ride and over heated and killed my Thermostat so I put Open Loop Cooling kit on it and took it out and the rpm wont go over 7540 and dusent fell as pepy in the throdel now to it lags
    Check your compression, you might have a bad head gasket.

    Please give a little more info tho, like it happened right after you changed to open loop? when where you seeing 8250RPMs? Any other changes done other then open loop? Have you checked your SC Slip? How many hours on the boat?

  3. #3
    ONELEGMAN not oenlegman
    Join Date
    Jan 2010
    Location
    austin texas
    Posts
    17
    sorry ya after it over heated and killed my thermo I put the open loop cooling so i cod run it. so ya i think now when I over heated it probably damage head gasket or piston ring
    the boat have 126h on it

    sorry for being a nub but what is the sc slip

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by oenlegman View Post
    sorry ya after it over heated and killed my thermo I put the open loop cooling so i cod run it. so ya i think now when I over heated it probably damage head gasket or piston ring
    the boat have 126h on it

    sorry for being a nub but what is the sc slip
    I would check the compression on your Cylinders, if they are all about 140 or so then the next thing I would check would be your SC Slip.(Supercharger Slip). You would need to pull out your supercharger for this and need a torque wrench to check your slip. Try searching and see if you have any luck on how to check it.

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Check for a boost leak

  6. #6
    ONELEGMAN not oenlegman
    Join Date
    Jan 2010
    Location
    austin texas
    Posts
    17
    cool thank

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    How long did you run the ski after the overheat?

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Were you blowing coolant out when you were running closed-loop?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 07-17-2016, 07:30 PM
  2. 2014 new to me rxp x,with new dress
    By jocolo in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-24-2016, 09:22 AM
  3. need help hi temp with new ecu
    By mikelytle1077 in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-17-2011, 05:33 PM
  4. 04 RXP bogging with Les ECU
    By Water4fire in forum 4-Tec Performance
    Replies: 21
    Last Post: 05-12-2010, 09:17 AM
  5. New ECU...Low RPM Mode??
    By allstar71 in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 10-21-2008, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •