Results 1 to 3 of 3
  1. #1

    Polaris engine problem

    We have a 1995 Polaris, 650cc watercraft. Any suggestions for this? When in the water, can't go over idle speed - no power. Out of the water, when reved up the engine pops and missfires. We have only changed the spark plugs at this time. What to try first? We ran it for a while without problems - then this all of a sudden.

  2. #2
    first thimg I would do is pull the carbs clean them out and replace the fule lines , vent lines clean the fuel selector start with the basics its cheep and almost anyone can do it. Also pull you spark plug boots off they just pull right off the wire and cut the wire back a half inch put the boot back on another free easy tune up item people over look. Good luck

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

    Click below, start reading

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with 95 Polaris SLT 750
    By cubsfan2516 in forum Polaris How To & FAQs
    Replies: 17
    Last Post: 05-03-2008, 07:50 PM
  2. 2000XPL Engine Problem
    By jetboy in forum 2-Stroke Performance
    Replies: 9
    Last Post: 09-26-2007, 02:56 AM
  3. Yamaha engine problem
    By surfside650 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 08-05-2007, 09:23 PM
  4. Polaris SLTH Problem!
    By smoke20 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 07-19-2007, 01:30 PM
  5. 1994 Polaris SL 750 problem
    By Playtime in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-24-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts