Results 1 to 9 of 9
  1. #1

    1996 GTX (787) Limited RPMs... HELP!!!

    My problem is my GTX will not rev above 4k rpm. Acts as if there it in a "limp mode" but have read the ski does not have this. When the ski first gets in the water it will run GREAT for approx. a hour or so and then all of the sudden it will not get above 4k rpms. If i kill the motor and immediately restart it (i mean like 1 second later) it will rev up to about 6500 for about 10 seconds and then cut back to 4k. Kill it / restart and it will continue to do this forever. If I let it sit for an hour or two I can ride for about 10 minutes before it cuts back to 4k. If it sits overnight I can run for another hour or so before it happens. I just don't understand why I can kill the engine and restart in 1 second later and it will run fine for 10 seconds or so. Electronics getting hot? Rave valves have been cleaned. Plug wires trimmed. What next? Please help!!! Thanks in advance for those who take the time to reply.


  2. #2
    I am having the same issue as well! Someone help us out here...rectifier?? I have run new fuel line and everything and I cleaned out my carb filters again and it ran great for a few minutes...then the same symptoms as ^. (not to hijack your thread...u described exactly what I am experiencing!)

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    yes that would be the rectifier as the source of your problem

  4. #4
    thanks for the reply airbornexp... Should I be able to unplug the rectifier and run the ski to verify this is my problem? Is there anyway to test the rectifier with an ohm meter / multimeter?

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    no not really....Id unplug it after it starts to bog. unplug it and see if it fixes it. if it doesnt work you have deeper problems

  6. #6
    thks again for the help... I'll unplug all 4 wirings to/from rectifier next time i get on the water and it starts to act up. Hopefully this will be the problem... pretty simple and inexpensive fix!! that's not how my luck usually runs

  7. #7
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    you just have to unplug the red wire

  8. #8
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Quote Originally Posted by airbornexp View Post
    yes that would be the rectifier as the source of your problem
    The rectifier is part of the charging system and shouldn't affect how the engine revs. I went through 2 rectifiers. I didn't have a problem with the engine reaching high rpm. It would just run until the battery didn't have enough vlotge to support the electronics and then die. I wasn't able to restart because of low voltage. I believe my problem is solved ( I won't be satified until I can run it a coulple of more times). I had to clean the metal shavings out of the mag cup and stator, replace the rectifier with higher amp 4tec one and put a ne DEKA battery in. I'm no ski tecnician, just a hobbiest.

  9. #9
    the rectifier does affect the engine rpms. I know because mine did. It had the same problems as the users posted, i tested the voltage from the battery, saw that it was not right, replaced it and it did fix my engine rpms. I could be wrong but i believe the higher voltage from a bad rectifier is like having a bad radio signal with static for the cdi.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 GTX ENGINE IS TOAST help with game plan
    By RBEAU1911 in forum 2-Stroke Performance
    Replies: 35
    Last Post: 05-07-2014, 08:06 PM
  2. FS - Parts Seadoo 1996 gtx 787\800 mpem only brand new in box p/n 278 000 897
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-07-2014, 04:32 PM
  3. Idle speed on 1996 GTX 787?
    By CZSteve in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-01-2013, 12:14 PM
  4. 1996 gtx rev limiter???
    By barmenta in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-27-2011, 03:03 PM
  5. 1996 gtx 787 stator?
    By sr240 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-14-2010, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •