Results 1 to 6 of 6
  1. #1

    js440 wont stay running

    i just put this ski together engine was in good shape when i got it never ran it but decided to do a top end rebuild just to clean things up. i finally put things back together fired it up and it runs but when you give it gas it just dies like its getting too much air and not enough fuel. i set the carb to the recomended settings. also found weird when i pull the choke it runs alot better. any ideas what could be wrong? thanks, Dustin.


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    If it runs better with Choke (less air) you are way lean. need to open the fuel mix up a little. What carbs to you have. Some are Air Mix (in for more fuel) some are Fuel Mix (out for more fuel). You might also have a leak in your case seals or fuel lines

  3. #3
    I know it's a makuni but I'm not sure on the size I thinks it's a 38 it's the small one

  4. #4
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    38 has 3 bolts holding it down 44 has 4 bolts

    If a BN38 then turn the high speed screw out 1/8-1/4 turn and see what happens. If better, turn again, check again. Keep going up until it gets worse again, then back off 1/4 turn. Run for a while and then do a plug chop. Full throttle toward the beach, kill engine from full throttle, swim ski in and pull plugs. they should be chocolate brown and dry. If lighter than milk chocolate, you are lean. If darker or oily, you are rich

  5. #5
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    sorry you were talking low end/idle. Turn the low speed out 1/8-1/4 and see how it runs. Once warm, if you pull the choke it should sputter, not run better

  6. #6

    Join Date
    Jul 2008
    Location
    Granbury, TX
    Posts
    130
    +1
    1
    check the pilot jet...10 to 1 it has some crap in it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage TXI wont stay running DI
    By ncdoo in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-23-2012, 09:43 PM
  2. Fuel pump wont stay running
    By bandit82184 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 03-27-2010, 08:14 PM
  3. 650 wont stay running
    By sammy64 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-31-2009, 02:08 PM
  4. Replies: 7
    Last Post: 04-14-2009, 09:22 PM
  5. Slt 750 wont stay running
    By xtrema2 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-03-2008, 09:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •