Results 1 to 7 of 7
  1. #1

    PROPLEM ,,Gages not working

    rpm gage is not working ... My fuel, speed and rpm gages not working.

    only the Volts is working ,
    what could be the proplem , i checked all the conectors and wires that i can reach and nothing.

    any idea whats i need to look for

  2. #2
    afc's Avatar
    Join Date
    Sep 2009
    is there no fuses in the ecu box ?

  3. #3
    Quote Originally Posted by afc View Post
    is there no fuses in the ecu box ?
    i checked all ,,are ok

  4. #4
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Wylie, Texas
    Has someone messed with the map? That has settings to communicate witth the stock display.

  5. #5
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    San Leandro, CA
    I and one of my teammates had a similar issue. Our RPM's stopped working. With both have MoTeC. The problem was the MoTeC KTC Unit. It converts MoTeC speak to Yamaha speak. It got wet and stopped working. After drying out for 10 days, mine started to work again. The unit is suppose to be sealed, but I guess it is not as sealed as they wanted it to be.

    What I have done to make sure it does not happen again was move the KTC Unit as high as I could and I put gorilla tape around it to seal it and to secure it more so it won't bounce around. You want the wire that goes into it point SOUTH. This is so water that may get on the wire does not funnel water towards the unit and seep in. Attached below is a pic of the KTC Unit. I unplugged it (noted by the red arrows) and let it sit. However, with my boat, everything worked but the RPM's. The Speedo should still work because MoTeC does not control that.

  6. #6
    Professional Alike Racer Clazz. Teerayoot's Avatar
    Join Date
    Jun 2010
    Koa LumPoo!,Thailand
    Mine too,but signal from blue/green wire are good log by Inovative LM2

    but stock dail not working ,
    how to repair it ?

  7. #7
    i switched the gages from another ski and its worked fine ,,i might just take gages a parts and see if there is any fuse inside

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Reverse not working
    By PeaceRiverRider in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-01-2008, 02:15 PM
  2. Vts not working
    By eclipsecleaning in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-10-2007, 07:32 AM
  3. Anyone in MI working on 04 RXP SC's?
    By doc212121 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-01-2007, 08:41 PM
  4. Speedo not working...
    By hedghog in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-13-2007, 02:56 PM
  5. Trim not working?
    By YJSONLY in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 02-10-2007, 02:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts