Results 1 to 7 of 7
  1. #1
    Pole rider and couch speed freak!
    Join Date
    May 2010
    Posts
    87

    How many RPMS should the GTX Wake 155 turn in the heat? Low power issues?

    Got one down a little I think, but it has a new prop/wear ring that looks like it has 0 clearance..............may be loading the motor too much.

    New plugs, oil changed and at proper level too........................

    Anything else cause an rpm loss? IT runs strong and smooth everywhere, but will only turn 6600-6700...........................

    Seems a little low............................

    Are these motors geared more for torque than others, or are they all the same (Cams, cam timing, etc)


  2. #2
    Pole rider and couch speed freak!
    Join Date
    May 2010
    Posts
    87
    Bump......................

    No one knows the "normal" rpms for the NA 4 tec motors?

  3. #3
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    I have a 155 gti and I see about 7600 rpms.

    And it was 90* F air temp

  4. #4
    Wakemeup's Avatar
    Join Date
    Apr 2008
    Location
    Alberta, Canada
    Posts
    7
    Quote Originally Posted by philip clemmons View Post
    Got one down a little I think, but it has a new prop/wear ring that looks like it has 0 clearance..............may be loading the motor too much.

    New plugs, oil changed and at proper level too........................

    Anything else cause an rpm loss? IT runs strong and smooth everywhere, but will only turn 6600-6700...........................

    Seems a little low............................

    Are these motors geared more for torque than others, or are they all the same (Cams, cam timing, etc)
    I have an 05 155 Wake and was running around 7400 rpm prior to changing the stock intake system over to a filter mounted directly onto the throttle body. Now I hit the rev limiter whenever I pin it which is around 7800 rpm. I also just changed my impeller to a Solas 11/19 and a new wear ring and will be trying it out this weekend. I wanted to try it first without the new impeller to see how much af a difference it was goiing to make. I'll let you know how it does...... if I loose power or not.

  5. #5
    I would guess the new impeller may be a different pitch than the stock one it replaced.

  6. #6
    Pole rider and couch speed freak!
    Join Date
    May 2010
    Posts
    87
    Quote Originally Posted by 8 is enough View Post
    I would guess the new impeller may be a different pitch than the stock one it replaced.
    Nope, this just occurred during riding apparently. It was "OK" at 65 ish on the speedometer (according to customer), now only runs 52-53 @6700. What ever happened is something that went south, not that was installed.

    I suspected the impeller too until I got details.........................

  7. #7
    Wakemeup's Avatar
    Join Date
    Apr 2008
    Location
    Alberta, Canada
    Posts
    7
    Ok. I just got back from the weekend running the new impeller and wear ring and wow what a difference. The machine takes off like a rocket. I guess i didn't realize how bad my old impeller and wear ring was. The rpm's dropped by 700 and I'm no longer hitting the rev limiter. Stock impeller is a 10/20 pitch and the Solas impeller I installed is a 11/19 pitch. I noticed the biggest difference out of the hole with a drop in top speed of about 2-3 mph. 60 mph is still fast enough for me. Pulls the tubes and wakeboarders no problem at half the throttle I used to pull at.

    Thumbs up to Jerry at 4 Tech Performance for getting my parts to me on time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how many hours should the new stator pump bearings last?
    By andy95'slx780 in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 01-01-2012, 10:40 PM
  2. How many hrs should I wait to install the 4" intake?
    By Rutcutter in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-21-2011, 10:22 PM
  3. how many psi should the tank holds?
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 37
    Last Post: 09-10-2010, 12:18 PM
  4. How many rpm should I be turning on 08 250 Ultra
    By aaron8473 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-07-2009, 05:11 AM
  5. Replies: 5
    Last Post: 08-02-2005, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •