Results 1 to 10 of 10

Thread: Rave Issue

  1. #1

    Thumbs down Rave Issue

    Hey guys fairly new to these forums so ive been searching around for info on a newly acquired xp limited , I have gone through the ski top to bottom since purchasing it including cleaning the carbs rave valves oil ect. but i still am having a problem with my rave valves. I first suspected the solenoid so i disconnected the air line to it and found i had no air. Next I followed the line down and found it was split , so i inserted a joiner and thought problem fixed , well still no air so next I changed the inline check valve , now i am at a point where i am worried about case pressure (seals?) the ski still runs so i figure the cases must be generating a pulse? (carb pulse line) I cannot feel a leak down below when it is running... any help would be appreciated.
    Thanks Shaun


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    they only open at peak RPMS, I believe around the 62,63000 mark

  3. #3
    Yes I understand that. The solenoid at whatever rpm range will open and allow air to the valves. Which was not happening so i troubleshot it further back and realized there is no air to the solenoid. Aswell when i remove the check valve and put my finger over the line exiting the cases it seems to me no pressure is being built only suction which would imply case pressure is leaking somewhere else?
    Thanks Shaun

  4. #4
    update checked reeds they are in perfect condition sealing well with no knicks or cracks.....still searching

  5. #5
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    I believe you got a bad or backards check valve, you should only get pressure and not suction, suction WILL eventually lean out your engine, there should only be pressure goin to the solenoid, not vacum, you can test the solenoid by isolating it and driving a 12 volt current through it, you should hear it "click"

  6. #6
    when i said there was no positive pressure that was after i took the check valve off. (to make sure that the spigot had not been clogged) , with the check valve on you get very very minimal air through the line and not nearly enough to activate rave valves I am beginning to suspect a PTO side crank seal , and therefore not being able to create enough positive case pressure......

  7. #7
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    only way to find out is to do a leakdown test, you can leakdown test with the rave valves in place, I used a intertube to block the intake and exhaust ports, using the manifold and the carbs atached, no need to go and spend hundreds on a kit you will barely ever use.

  8. #8
    Alright that looks like the next step , I wish it wouldnt have come down to this, but what can you do. Thanks for your help.

  9. #9
    It would not run right if it didn't have enough positive pressure in the PTO side. I would suspect a bad check valve first. You cannot tell anything without the check valve installed as it alternates between vacuum and pressure. Replace the check valve and see if this gets you some positive air flow.

  10. #10
    , well still no air so next I changed the inline check valve , now i am at a point where i am worried about case pressure
    that was exactly my thinking as well so i ordered a new check valve and installed it and still only had the most minimal amount of air (does not even blow on the back of your hand you can just to say feel a very very small air pulse ) i had the check valve off only to check if i had any air moving through the spigot and that it was not plugged. (which it was not) I do not see typical crank seal failure signs such as idle or surge , but I cannot think what else it might be.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oversizing a 787 engine, rave issues.
    By aruba yamaha in forum 2-Stroke Performance
    Replies: 13
    Last Post: 12-24-2013, 11:08 PM
  2. 96 GSX Rave issue
    By barondurden in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-14-2010, 07:45 PM
  3. 951 DI Rave Valve issues............
    By philip clemmons in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-13-2010, 06:24 PM
  4. 951 RAVE valve issue
    By radeon in forum 2-Stroke Performance
    Replies: 17
    Last Post: 07-13-2010, 12:28 PM
  5. 2001 951 DI RAVE valve issue
    By race24x in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-11-2010, 03:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •