Results 1 to 10 of 10
  1. #1
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227

    Can anyone think of anything else worth checking?

    Appreciate you guys looking over my shoulder. So far I've cleaned out the water manifold, reconnected properly all the exhaust and stinger pipes. All flowing properly now.
    Put new cables to spark plugs,
    Replaced plugs,
    greased and lubricated everything I can think find in the manual, cables, joints etc.
    Fixed broken negative wire to stator
    Planning to do do water routing mod (need to get my hands on a valve see seperate post)
    Greased drive shaft,
    Planning to take carbs out and rebuild and replace fuel lines but think thats probably best left until winter.

    Only thing that shows on display is low pr - I've installed a brand good quality battery and charged it for recommended hours so just need to check it's output. Unless there is another common fault for this happening.

    Spotted something which has me questioning the previous owners ability to look after a ski so I'm checking everything. They used a cable tie to secure the fuel line on the pta carb! See pic



    Click image for larger version. 

Name:	CIMG2811.JPG 
Views:	30 
Size:	168.9 KB 
ID:	207571


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    that zip tie is factory and in the tech section theres a post on how to reset the mfd to get rid of the low power light

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Hey Matt you should start one thread for all your questions its much easier to follow. Sort-of like a build thread.

  4. #4
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227
    Cheers Lugs & Beer Dart

    I'll have a look for the low pr light thread and start a new threads for my questions.

    Matt

  5. #5
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227
    Quote Originally Posted by 785 lugs View Post
    that zip tie is factory and in the tech section theres a post on how to reset the mfd to get rid of the low power light
    Hi Lugs

    Had a good look through the posts and cant find the one reseting the mfd to reset the mfd and get rid of the low pr do you know how to do it?

    Thanks

    Matt

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    MFD reset procedure (CALibrate) can be found in the links below

  7. #7

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    i've been here 4 years and i still can't find things

  9. #9
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227
    Haha, just followed your intructions and calibrated the mfd all is good, low pr gone and the fuel and oil now reading correctly. Thanks Lugs!

  10. #10
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227
    Cheers k447! Going to be really cheeky but can you guys help me with this?

    http://www.greenhulk.net/forums/show...lve&highlight=

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 10-04-2014, 04:20 PM
  2. 2009 STX not starting - can anyone help with possible things to check
    By 454spyder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 09-02-2011, 07:38 PM
  3. So will the fuel pump out of anything else work on my 03 gpr1300?
    By DONALDBUCHANAN in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-26-2010, 10:10 AM
  4. Is anyone thinking of selling in the fall?
    By cincygpr in forum Yamaha Classifieds
    Replies: 5
    Last Post: 07-09-2008, 08:27 PM
  5. New design and can't think of a title???
    By SideFX in forum Open Discussion
    Replies: 19
    Last Post: 12-11-2007, 12:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •