Results 1 to 3 of 3
  1. #1
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227

    pro 785 - brown deposits on exhaust valves?

    Is the brown stuuf normal or do I need to clean/service?

    Cheers

    Matt
    Click image for larger version. 

Name:	CIMG2774.JPG 
Views:	67 
Size:	234.2 KB 
ID:	207598


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Looks like rust but theres really nothing there to rust up just make sure you can move them up and down with your fingers and they should be fine

  3. #3
    matt160580's Avatar
    Join Date
    Jul 2010
    Location
    Lancashire, UK
    Posts
    227
    Cheers lugs yes they move fine and snap back into place so alls good. Just the brown spray coming of them had me curious! Cheers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 Pro 785 without a thermostat popoff valve
    By sdlvx in forum Polaris PWC Performance
    Replies: 31
    Last Post: 05-22-2011, 02:25 PM
  2. 98 pro 785 in texas on ebay
    By ujustlost in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-09-2011, 08:42 PM
  3. Pro 785 wont run on the water
    By jcjw1998 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 08-27-2010, 11:16 AM
  4. 00 PRO 785 Trim Display On MFD Does Not Match Trim Position?
    By mccann316 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-09-2010, 11:32 PM
  5. FS Pro 785 Triple Pipes With Jetworks Valve
    By seatsR4toilets in forum Polaris Classifieds
    Replies: 10
    Last Post: 03-14-2010, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •