Results 1 to 5 of 5
  1. #1

    97 GTX "squeeking" on acceleration - Jet Pump going?

    The GTX is starting to make a squeeking sound when you accelerate. How long before the pump totally fails, or has it already? Or is this some other tragedy.


  2. #2
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by SBINBRANSON View Post
    The GTX is starting to make a squeeking sound when you accelerate. How long before the pump totally fails, or has it already? Or is this some other tragedy.


    Well going by what you are saying and the fact I can't hear your noise, if you suspect the pump then pull the steering nozzle off and then the cone. Have a look at the oil and see if there is water and rust present. Might even be better to just pull the pump so you can rotate the bearings by hand. That is where I would start if I suspected my pump getting ready to go. As far as how long you have, who knows. The thing is to not wait till you hear KABOOM!

  3. #3
    Quote Originally Posted by RumRunnerRon View Post
    Well going by what you are saying and the fact I can't hear your noise, if you suspect the pump then pull the steering nozzle off and then the cone. Have a look at the oil and see if there is water and rust present. Might even be better to just pull the pump so you can rotate the bearings by hand. That is where I would start if I suspected my pump getting ready to go. As far as how long you have, who knows. The thing is to not wait till you hear KABOOM!
    Ron, thanks for the note. I'll pull it out of the water and take a peek at it. Though given the age of the craft, hearing the Kaboom might be interesting way to ay goodbye to it.

  4. #4
    Took off the cone, total devastation of the pusher and spring. Metal fragments everywhere. Looks like I have a bit or reparing to do. What type of lubricant do I use here?

  5. #5
    mine 99 gsx did that it was the thrust bearing and boy was it bad not even a ball left in the bearing working on fixing it now actually need all new housing bearings and seals, im hoping the driveshaft is still in working order!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 04-17-2015, 09:39 AM
  2. my 97 gtx wont stay running on water
    By provo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-01-2011, 09:15 AM
  3. can the jet pump from a 97 SPX work on a 97 GTX
    By Warren Hardguy in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-06-2010, 05:26 PM
  4. Replies: 1
    Last Post: 06-30-2008, 10:15 PM
  5. Dead hour meter on '97 GTX
    By KevinS in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-14-2007, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •