Results 1 to 6 of 6
  1. #1

    polaris virage problems

    I have a 2002 polaris virage i 8oo it starts and runs great for about 15 to 20 minutes then the rpm start to get erratic and it starts bogging then it will just cut out completely ive checked the tps all fuel lines and blown out all the water lines. It will run fine on the hose all day only in the water at high rpms does it mess up someone said the coil might be bad or heating up and seperating or something any one have any ideas and also does any one know if anybody works on polaris's in the titusville florida area any help will be appreciated.
    Jamey


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    How did you check the TPS?

    The only reliable test for a TPS is to install a new or known good TPS.

  3. #3
    you were the one who told me before to pull the plug off the tps when it started messing up and if it idled fine unplugged without trying to give it gas that the sensor was the problem i did that and it still wouldnt fire back up.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    Quote Originally Posted by Jamey1985 View Post
    you were the one who told me before to pull the plug off the tps when it started messing up and if it idled fine unplugged without trying to give it gas that the sensor was the problem

    I did that and it still wouldn't fire back up.
    Some EMM don't allow the engine to idle without the TPS. Not sure why, but it happens.

    If it idles without TPS, and does not idle with TPS, then the TPS is often the problem.

    The reverse case is different. If it does not idle with and without TPS, then the TPS may or may not be good.

  5. #5
    ok thanks, but do u think that the coil could have anything to do with whats its doing. next time i take it out to mess with it im going to shoot some video of whats its doing.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    Quote Originally Posted by Jamey1985 View Post
    ok thanks, but do u think that the coil could have anything to do with whats its doing. next time i take it out to mess with it im going to shoot some video of whats its doing.
    Not sure why you are focusing on the ignition coil. The coil can fail, but it is not a common failure.

    If changing the TPS doesn't fix it, then I would tend to suspect the EMM needs repair. It may NOT be the EMM, but that would be my suspicion.

    Do check the EMM water cooling hoses. Makes sure they are not kinked, and are flowing water. An overheated EMM may not trigger a fault code or red lamp.

    If you ARE seeing a red warning lamp and Check Engine message, then you can read the EMM Service Codes to see what the EMM thinks is the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris virage problems
    By Jamey1985 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-01-2010, 08:56 AM
  2. 2000 Polaris Virage problem
    By em-dubya in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-31-2010, 09:36 PM
  3. 2002 polaris virage Problems
    By Cowboyffa84 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 07-01-2010, 07:03 AM
  4. Fuel Problem-Polaris Virage 2000
    By joecarta in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 04-01-2008, 09:34 PM
  5. 2002 Polaris Virage I Electrical Problem
    By gusie1 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-30-2007, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •