Results 1 to 3 of 3
  1. #1

    sea doo 720 no spark

    plug in dess get two beeps,motor cranks over fine ,no spark. if i take the wire off the back of the coil and put a test light on it and crank the motor the light pulses. is this a bad coil ???? any help

  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Mahomet, Il. USA
    you may want to try cleaning all the connection points at the coil. trim back the plug wires enough where you see clean metal as they may be corroded. check your grounds also and make sure that there is no corrosion under the shrink wrap. if there is replace the ground wire.

  3. #3
    thanks airborn i tryed changing the plug wires no luck also checked all grounds. this coil is not like the 96 xp coil with the two wires. this only has 1 wire and grounds with the mounting screw.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sea Doo 720 HX Factory Pipes
    By bgnsty in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 06-18-2016, 12:14 PM
  2. Sea Doo 720 MSD Total Loss
    By bgnsty in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-05-2008, 04:54 PM
  3. Sea Lion on Sea Doo.....
    By liner911 in forum Videos & Pictures
    Replies: 4
    Last Post: 03-01-2008, 11:40 AM
  4. Sea Doo 3D
    By RXP22 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 09-21-2007, 05:00 PM
  5. sea doo re doo!!! haha blew it away today not a chance
    By BMW550I in forum Kawasaki PWC Performance (4-stroke)
    Replies: 159
    Last Post: 06-18-2007, 09:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts