Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    polaris genesis 1200 i 2003 PLEASE HELP!!

    Hi, let me start by saying thanks to K447 for your help with my polaris 1200 i genesis, I was having probs when I went past half throttle, I replaced the TPS, PLUGS LEADS & CAPS, and the CPS, but still had the same probs, came on here and I saw the fuel tank pressure post, so off I go and yes you were spot on about the pressure regulator, so I put it back and checked pressure and it was back to 20 psi, but it was hard to start and now if i can get it to start it will not stay running and is miss firing and back firing bad enough to blow off the exhaust hoses, it would appear that the ignition timing has been thown out any info would be greatly received, I see you have put a post for a wiring diagram for accessing fault codes but I live in the uk with no polaris dealer near me could you tell me where to get the software please?
    thanks for all your help Mark.


  2. #2
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    I also have a 2002 polaris genesis i and have problems. Just out of the shop and it ran fine for a while then died. After that, it would try to start but would just backfire. The shop says its the emm but I am not confident in that. Any ideas?

  3. #3

    Join Date
    Jun 2008
    Location
    Sudbury, Ontario
    Posts
    109
    Do you have spark at each of the cylinders, are the coils hooked up properly. I had a similar problem, previous owner had 1 and 3 crossed at the coils.

  4. #4
    I have a 2000 genesis FFI and had similar problems including a few others, replaced all the sensors and still had problems. I sent the EMM to DFI Tech for repairs and they said that it was damaged, now I am impatiently waiting for it to get back. lol

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jackofalltrades View Post
    I also have a 2002 Polaris Genesis i and have problems. Just out of the shop and it ran fine for a while then died.

    After that, it would try to start but would just backfire. The shop says its the EMM but I am not confident in that. Any ideas?
    Welcome to the Hulk

    EMM can fail, and backfiring is one of the symptoms of a bad EMM. Backfiring can be from other things, but a bad EMM is high on the list.

    Why are you not confident in the repair shop's diagnosis?

    BTW, rather than hijacking someone else's thread, best practice is to start your own thread in the General section.

    Click the links in my signature for some useful info.

  6. #6
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    Thanks for the warm welcome to the forum. As for the etiquette, I will have to learn as I go because this is my first forum . Is there a user guide for this thing besides the general rules I read when I signed up? Anyway, to answer your question about the repair shop, there have been lots of things replaced on this ski and even though it runs when they give it back it dont for long. Also, the previous owner told me the shop hooked the battery up backwards one time so no wonder the computer might have went. Long story short, they spent $3000 in repairs in the last 2 years on this thing and finally gave up and sold it to me for $400 with the trailer.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Short answer is to send the EMM off to DFI Technologies. If it is OK, they will tell you so, and the charge is reasonable.

    Be aware that the LR Start/Stop module MAY also be bad. If it is, you can order a new one, or buy a good used one. The EMM is the likely suspect.

    Parts Sources are linked from my signature.

  8. #8
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    I think that is the best option at this point. As for the start/stop module, would it still do the same thing once the emm is repaired? Also when I send in the unit to DFI, will it need to be re-programmed once they return it since the fuel injectors are flow mapped to the emm?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by jackofalltrades View Post
    I think that is the best option at this point.

    ...when I send in the unit to DFI, will it need to be re-programmed once they return it since the fuel injectors are flow mapped to the emm?

    As for the start/stop module, would it still do the same thing once the emm is repaired?
    DFI will not alter the injector programming in your EMM.

    If the Start/Stop module is damaged, it will need replacement. It will not harm the EMM to try it after repair with the existing Start/Stop module.

  10. #10
    sorry its been so long for me to post back on here and thanks for all your
    help and thanks to k447 as once again you where spot on
    the fault was the emm just took a long time to get one !
    thank again mark.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polaris genesis ground/emm issue?? please help
    By CJW2016 in forum Polaris Open Discussion
    Replies: 66
    Last Post: 06-10-2016, 05:00 PM
  2. 2002 Polaris Virage TXi and 1999 Polaris Genesis 1200 Help!
    By Big Willy in forum Polaris Open Discussion
    Replies: 22
    Last Post: 01-23-2016, 11:31 AM
  3. 2001 Polaris Genesis FICHT WONT START PLEASE HELP!!!!
    By xBrenneckex in forum Polaris Open Discussion
    Replies: 37
    Last Post: 07-02-2013, 08:04 PM
  4. 2002 Polaris TXI 1200 Won't Start Help please.
    By deepsouth in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-04-2011, 06:16 PM
  5. Help with a 2000 Polaris Genesis 1200
    By hammerurhouse in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-15-2009, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •