Results 1 to 7 of 7
  1. #1

    94 raider grinding or growling

    Was out on the river it picked up a loud vibration (grinding sound from the pump) stop looked for something in the pump nothing found. Going back to the dock it kept getting louder finally it quit but now sounds like a rock rolling around in a can when you start the motor. It's definetly in the pump but I can not find anything loose or worn out.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0923.jpg 
Views:	45 
Size:	117.1 KB 
ID:	207930  

  2. #2

    Join Date
    May 2010
    Bettendorf, Iowa
    I had a similar problem and mine was the rubber drive coupling. It was worn and crated a "wobble" effect. It went from noisy to shaking the whole Raider in a hurry. You may want to check that out.

    If not, another guess - pump bearing?

  3. #3
    Well got it apart sorta. It is bad bearings in the rear housing. But I can not get the impellar shaft out. It should pull out of the coupler inside the hull right? I tryed pulling hard, a slide hammer and tapped on the impeller with a block of wood and a hammer from under the boat no luck. I have never seen one stuck like this or I'm I missing something.

    Best place to get parts??????


  4. #4
    Anyone know the size and pitch of the threads on the end of the impellar shaft. If I had that I might be able to find a nut and make a better attachment for the slide hammer.


  5. #5
    Finally got it out with a slide hammer. Welded some large washers on a piece of tubing then sawed it into length wise put it around the shaft with a hose clamp. The washers caught on the step in the shaft hooked the slide hammer to the other washer and bang a few times it came out.

    I know the date is wrong on the pic's
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	jet ski 00002.jpg 
Views:	37 
Size:	54.4 KB 
ID:	208988   Click image for larger version. 

Name:	jet ski 00001.jpg 
Views:	37 
Size:	66.0 KB 
ID:	208989   Click image for larger version. 

Name:	jet ski 00000.jpg 
Views:	35 
Size:	50.9 KB 
ID:	208990  

  6. #6
    I was looking for parts and found a 2000lx crashed. It has the 700cc motor but the pump is 155mm. I was thinking about changing out the entire pump system will it work in my 1994 raider?


  7. #7
    Anyone somebody has to know if it will work????????????????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Grinding Sound
    By prosportsman in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-25-2008, 09:28 AM
  2. Grinding, roar in fxho
    By wolfmad in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-18-2007, 05:13 PM
  3. grinding the impeller
    By loveboxer in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-17-2007, 07:02 AM
  4. ff plate grinding
    By Hydrotherapy in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 04-29-2007, 10:40 AM
  5. grinding pump ?
    By thrasher63 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 03-24-2007, 07:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts